This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Itamar 6 months ago.

Assigned support staff: Itamar.

Author Posts
April 22, 2019 at 9:47 am

steveK-13

I am trying to translate page to 2nd language, but "Translate Independently" button don´t work.

Link to a page where the issue can be seen: hidden link (password: 12345)

I expected to see translated page and I see, but after i make changes on 1st language, the translation get lost.

April 22, 2019 at 10:21 am
April 22, 2019 at 10:22 am #3655117

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

For some reason, you were disconnected from the chat. Let's please continue like this with when it is a regular ticket.

April 22, 2019 at 10:24 am #3655123

steveK-13

lost connection, how can get back?

April 22, 2019 at 10:45 am #3655191

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

On your English page, I could see that it is a duplication of the Estonian page. So I pressed the Translate independently button. Please see the attached screenshot english-trans-ide.jpg. And now you would be able to edit the English page independently.

But please let me ask the following.
Are you creating this page with the WPBakery Page Builder?
I can see that it is active on your site.
If so then please follow our instructions on how to work with WPML and the WPBakery here.
https://wpml.org/documentation/plugins-compatibility/how-to-build-multilingual-sites-with-wpbakery-page-builder-and-wpml/
In this case, for the best translation experience, you would also need to activate WPML's Translation Management add-on.

Please let me know if this information is helping you to solve the problem.

Regards,
Itamar.

April 22, 2019 at 10:48 am #3655247

steveK-13

I clicked it too, but nothing happened. I will test

April 22, 2019 at 10:53 am #3655261

steveK-13

then I activate WPML's Translation Management plugin then I can´t translate the page like normal, shows fields like on pic, but not all the content hidden link

April 22, 2019 at 10:56 am #3655265

steveK-13

then I deactivate this plugin, then can translate, but it will not stick, there are "The Content Template is copied from the original language"

April 22, 2019 at 10:59 am #3655267

steveK-13

Can´t use without this WPML's Translation Management addon and translate independently?

April 22, 2019 at 11:12 am #3655319

steveK-13

then I use this addon I can only translate media, I don´t see any content like on manual https://wpml.org/documentation/translating-your-contents/page-builders/#translating-page-builder-contents

April 22, 2019 at 3:49 pm #3656889

steveK-13

any suggestions?

April 22, 2019 at 5:56 pm #3657661

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

OK, I've further checked things on your site, and I can see that you are using the Be theme with its Muffin page builder. You are not using the WPbakery page builder as I thought. In this case, when using the Muffin Builder, you need to translate the pages manually. It is mentioned in our documentation about how to work with WPML and the Be theme. You can see it here.
https://wpml.org/documentation/theme-compatibility/create-multilingual-wordpress-websites-using-betheme-and-wpml/#translating-muffin-builder-pages
So you would need to disable the use of WPML's Translation Editor on pages where you are using the Muffin page builder and translate those pages manually. Please read more about translating pages manually on our documentation here.
https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/

Please let me know if this information is helpful to you.

Regards,
Itamar.

April 22, 2019 at 9:11 pm #3658339

steveK-13

Hi,

It is not helpful. I have made many webpages, many with BeTheme and many with WPML. Problem is that this "Translate independently" button don´t work anymore. Tested it again, still same problem, clicked on button, but then I make any changes on Estonian page the changes will be also on English page. hidden link

Can you test: make changes on Estonian homepage: hidden link

and it will change English homepage hidden link

How can fix it?

April 23, 2019 at 2:45 pm #3664921

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I'm getting the following message when I press this link.
hidden link

This translation is currently in the trash. You need to either delete it permanently or restore it to continue

Please see the attached screenshot.
If you sent the translation to the trash section, it could also explain the problem that you are having.

Furthermore, I can't access your site now. When I try the password that worked for me, it does not work. Please see the attached screenshot.

If the issue persists although you restore the translation from the trash section, please share with me the access details again. I'm enabling a private message now.

Thanks,
Itamar.

The topic ‘[Closed] Translate Independently don´t work’ is closed to new replies.