This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 2 voices.

Last updated by Pedro Henriques 6 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
April 3, 2019 at 7:31 pm #3530179

Pedro Henriques

Internal links aren't translated automatically? How to "translate" this? hidden link

April 4, 2019 at 1:33 am #3531139

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Please, try the following:

1 - In your WordPress Dashboard > WPML > Settings > Translate Link Targets click the button 'Scan now and adjust links' and wait for the whole process.

2 - Now in your WordPress Dashboard > Settings > Permalinks click to resave the permalinks in order to avoid any page/post not found issue.

Please, let me know if it helps to fix your issue. Have a nice day.

April 4, 2019 at 6:30 pm #3537731

Pedro Henriques

Hello, Marcos

No, it doesn't fix. And process described in 1 stresses the server for hours! It can't be solution...

Any new suggestion?

Thanks

April 5, 2019 at 5:40 pm #3546203

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

April 9, 2019 at 3:04 am #3562493

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my private reply above. Thanks!

April 9, 2019 at 11:06 am #3565863

Pedro Henriques

Marcos,

What custom WPBakery blocks have you identify? If you are referring to FlipBox it's integrated with the Theme. It's a new element the developer introduced recently from a previous existing element with the same name. Previously to contacting WPML, I post the issue to theme support but they suggest contacting WPML to fix the issue.

Anyway, I tested it in the staging site (hidden link), as well as in the sandbox site, and it worked. Seems to be a problem with the conversion of the code of the previous Flipbox element?!

Suggestions for a fix, besides creating all FliBox elements again?

Thanks

April 9, 2019 at 7:17 pm #3570245

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I was taling about the custom blocks provided by your theme such as the 'FlipBox' block. With the sandbox test we have the confirmation it works, so in your case, the issue is something specific to your website settings, please, try the following:

1 - Change to the the parent theme instead the child theme from your WordPress Dashboard > Appearance > Themes settings.

2 - Disable all the plugins except the WPML related ones and those directly related to your theme.

3 - Clear all the browser cache.

4 - In your WordPress Dashboard > WPML > Settings > Translate Link Targets click the button 'Scan now and adjust links' and wait for the whole process. This is step is required to update all your internal links.

5 - Now in your WordPress Dashboard > Settings > Permalinks> click to resave the permalinks in order to avoid any page/post not found issue.

Please, let me know if it helps, have a nice day.

April 9, 2019 at 10:30 pm #3571081

Pedro Henriques

No, not working. I notice that in the existing FlipBox blocks the "link url" appears for translation ( hidden link) while if I create a new FlipBox it doesn't. It seems as tle link is not being recognized as a link but as text.

Suggestion?

April 11, 2019 at 1:31 am #3582497

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for your continued patience. I am jumping here to let you know I am currently working on your issue, I still don't have a working solution, some additional investigation is needed. I will update you here as soon as I get some details, thank you for your understanding and patience. Have a nice day.

April 11, 2019 at 1:30 pm #3588263

Pedro Henriques

Thanks, Marcos

After updating the new FlipBox block in test page the issue came up again and have to update the link manually:
hidden link

Looking forward to your feedback.

April 12, 2019 at 1:54 am #3593529

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my private reply above. Thanks!

April 12, 2019 at 2:09 pm #3599793

Pedro Henriques

Hello, Marcos
The site has been migrated successfully.
Looking forward to your feedback.
Thanks

April 15, 2019 at 5:59 pm #3615589

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the details and sorry for the bit of waiting due the weekend. I took another look in your website using the migrated copy and notice for every new page added the internal links of your Flibbox shortcode will work as expected, for the existing pages and translations it doesn't work, here some kind of server or database related cache seems to be the cause of the issue. Also in your stagging website, everything works as expected when a new page and new translations are added as you can see at: hidden link.

The only solution here seems to be to contact your server admin for any possible cache issue or if you don't have a lot of pages using the Flipbox shortcode to recreate the translations for these pages. Please, let me know it helps, have a nice day.

April 16, 2019 at 8:57 am #3620149

Pedro Henriques

Marcos,

Recreate the pages with Flipbox module isn't an option since every update to the link isn't working either (hidden link). It only works when it is created.

And how would we address the issue to the host provider? There is a cache system in the host server (hidden link) that I can disable. Besides that what questions should I put?

April 16, 2019 at 6:39 pm #3624765

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Pedro,

Thank you for the details. We have already a confirmation the Flipbox shortcode works properly with the custom xml code outside your environment, so in your case, the issue is indeed related to your server environment not the WPML plugin, this way here the only option is to ask your host provider to disable the cache mechanism and try the to update the page and translations where you have the Flipbox shortcodes again. We cannot deal with server configuration and issues, we hope you understand. Have a nice day.