This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by raulS-18 1 month, 1 week ago.

Assigned support staff: Bigul.

Author Posts
February 20, 2020 at 6:06 am #5529753

raulS-18

Now I am trying to edit those theme words, I have translated the spanish for Kalium but it continue appearing in english for example hidden link

here when you scroll down into the grid and load more posts is still in english...

Thanks for your time

February 20, 2020 at 6:48 am #5529845

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve the issue.

I hope you are trying to translate the *No more portfolio items to show* string loading at the end of the Portfolio page. If so, that string is not a part of string translation and it is set in Pagination settings of Portfolio Items Element by Kalium theme.

It is showing the expected result after I set the Spanish value for *No more items to show text* and then update the hidden link page and its English Translation.

Please check the attached images for more details and let me know your feedback.

--
Thanks!

Bigul

February 20, 2020 at 1:43 pm #5533319

raulS-18

Bigul thanks!

As this is my first WPML I have a lot to learn. Could you please tell me how to translate the footer into english please?

"© Copyright 2020 | Página web por OTUNDRA | Todos los derechos reservados"

"© Copyright 2020 | Website by OTUNDRA | All rights reserved"

February 20, 2020 at 2:50 pm #5533969

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup. The one you have shared for the previous ticket is cleared now.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

February 20, 2020 at 4:01 pm #5534749

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login details. The footer text is registered for translation in WPML>>String Translation. But the language of the string is English. So you can fix it by changing the language of the string domain to Spanish. Please try it after a site backup and translate the footer text string to English and Chinese.

Please check the following documentation and attached images for more details, and let me know your feedback.

https://wpml.org/documentation/getting-started-guide/string-translation/#original-language-of-strings

--
Thanks!

Bigul

February 21, 2020 at 11:48 am #5540039

raulS-18

Hi Bigul,
I have do it but the website still show in one language...
hidden link --> footer

February 21, 2020 at 2:12 pm #5541459

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. The issue is existing after enabling the following options of WPML String Translation and adding language configuration for the strings in WPML>>Settings>>Custom XML configuration(it already exists in your parent theme in *wpml-config.xml*). Do you have any server-side caches?

1) Track where strings appear on the site

2) Look for strings while pages are rendered

Please tries the following troubleshooting steps after a full site backup and make sure the issue is existing or not.

1) Go to WPML>>Support page

2) Click on Troubleshooting link (blue link in the middle of the page)

3) In the Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Assign translation status to duplicated content
- Cleanup and optimize string tables
- Show custom MO Files Pre-generation dialog box>>Generate .Mo files

If the issue exists, please switch for a moment to the Kalium parent theme and check is there any difference in the result.

--
Thanks!

Bigul

February 24, 2020 at 10:19 am #5553021

raulS-18

It's still not working...

February 24, 2020 at 1:58 pm #5555089

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please let me know the following for tracking the issue.

a) Is this issue is only happening with footer text?

b) Do you have any server-side caches?

c) The issue is existing when the theme is Kalium, not the child theme, am I right?

--
Thanks!

Bigul

February 24, 2020 at 3:42 pm #5555879

raulS-18

Surprise: Its only happening on child theme! But child theme has only 4 lines of css....

no server-caching, and yes only on footer.

What should I do?

February 25, 2020 at 6:38 am #5559391

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I shared the details with our second-tier team for the expert opinion and waiting for the feedback. We will get back to you soon. Please wait.

--
Thanks!

Bigul

February 25, 2020 at 3:22 pm #5564225

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

It requires further checking. So please allows me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

February 25, 2020 at 3:47 pm #5564407

raulS-18

Sure! can you make it yourself? — Thanks Bigul

February 26, 2020 at 6:18 am #5567871

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for your permission. I made a Duplicator copy of the site and debugged it on my local copy. This issue is happening because the *Text Domain* is not defined in your child theme. It is working on your site now after the following steps.

1) Add the *Text Domain* for the child theme
2) Visit WPML>>Settings>>Custom XML configuration
3) Add the language configuration to register the footer text
4) Visit WPML>>String Translation
5) Change the language of *admin_texts_theme_mods_kalium-child* string domain to Spanish from English
6) Translate the string

Please check the attached images for more details and let me know your feedback.

--
Thanks!

Bigul

February 26, 2020 at 9:40 am #5569125

raulS-18

Thanks a lot Bigul!! you are great 🙂