Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: When my translator is using the Machine translation from the new Advanced Translation editor, he can overwrite my URL Slugs to Chinese characters. I want to deactivate this and copy the default slug from the default language.

Solution: Please run the following settings: #1 WPML -> Settings -> “Translated documents options: Change to “Copy from original language if translation language uses encoded URLs”

#2 #3 Change under WPML -> Languages -> Edit Languages -> on the right drop down "URL Encode" to "YES" for the secondary language (In this Case Chinese Simplified).

Relevant Documentation: https://wpml.org/forums/topic/encode-urls-what-does-it-mean-if-i-put-yes-or-no/#post-1329540

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 25 replies, has 2 voices.

Last updated by olafM-4 1 year, 1 month ago.

Assigned support staff: Marcel.

Author Posts
July 23, 2019 at 9:55 am #4264767

olafM-4

Hi Marcel,
Your recommended settings for the slug translation does not create the desired result. We want the slug to be the same for English (source) and Chinese (translated new page). If the title is 团体活动:乘坐历史悠久的电车穿越米兰 then the slug should remain "historic-tram-through-milan" as it is in the English source of that page. See attachment 1.
The WPML Settings page shows these options:
Page URL
a) Auto-generate from title (default)
b) Translate (this will include the slug in the translation and not create it automatically from the title)
c) Copy from original language if translation language uses encoded URLs
We want option c). But we don't understand the "if translation ..."
In WPML Language settings we choose "Language name added as a parameter (hidden link - 中文)". And we also unchecked this option:
Slug translations: Translate custom post and taxonomy base slugs (via WPML String Translation). Unclear text. Again, we do not want to translate the slug.

I will leave the fresh translation for you to have a look. It is still in draft status but you will see that the slug is translated (bad), the button row in the center of the page has link targets to de instead of zh-hans (image 2), and the Masonry has lost the filer settings (image 3). The Chinese draft page is here hidden link
And the English source is here hidden link
And if someone would make the window bigger where to post this reply then it would be easier as well ...
It's complicated. Maybe we schedule a web meeting. What do you think?
Kind regards
Wolfgang

July 25, 2019 at 4:49 pm #4285237

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Wolfgang,

vielen Dank für die ausführliche Beschreibung! Ich glaube nun kommen wir der Sache schon näher. Ebenso erklärt dies nun, warum die Link Targets verschwinden. Ich lasse die gewünschte Slug Option nochmals gegenprüfen und hoffe wir kommen nun schnell zu einer finalen Lösung.

Ich wünsche Ihnen einen schönen Abend!

Freundliche Grüße
Marcel

July 29, 2019 at 12:59 pm #4299927

olafM-4

The screenshot attached indicates that the page created by the ATE in the new language does not finish the process. In this example, the translation was finished over 24 hours ago and it still says it has not been fully created. Maybe you find this observation helpful. This is error appears frequently.

July 31, 2019 at 8:43 am #4312997

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Wolfgang, ich habe eine Rückmeldung mit einer Anpassung der Einstellung erhalten. Ich teste dies nun auf der Testumgebung und gebe Ihnen schnellstmöglich Bescheid.

Freundliche Grüße
Marcel

August 6, 2019 at 9:52 am #4346003

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Wolfgang,

nun haben wir die korrekte Lösung.

#1 Bitte erstellen Sie ein volles Backup

#2 Stellen Sie unter WPML -> Settings -> “Translated documents options: -> auf “Auto-generate from title (default)”

#3 Dann unter WPML -> Languages -> Edit Languages -> Bitte aktivieren Sie rechts im Dropdown URL Encode auf "YES" nur bei Chinese Simplified

Funktionierendes Beispiel:
hidden link <-> hidden link
-> Der Title erscheint zwar im Advanced Translation Editor, eine Bearbeitung mit Chinesischer Schrift hat jedoch keinen Effekt mehr auf die Anzeige, da nun immer der Permalink der Default Sprache mit &lang=zh-hans dargestellt wird.

Hinweis: Sollten Sie beim Umstellen Permalinks wie z.B: "?post_type=portfolio&p=22919&lang=zh-hans" sehen, so muss der Beitrag in "Chinese" aus dem Draft Status heraus veröffentlicht werden. Dies ist bei Ihnen unter WPML -> Einstellungen so konfiguriert.

Freundliche Grüße
Marcel

August 6, 2019 at 12:24 pm #4347305

olafM-4

Hallo Marcel,

Danke fuer die Rueckmeldung. Ich habe im "dev2" Clone gleich nachgeschaut. Da sind die Settings wie Sie laut Ihrer Rückmeldung sein sollen. Dann habe ich eine neue Seite (Portfolio Entry) angelegt in Englisch.
hidden link
Diese Seite habe ich mit WPML in einen Uebersetzungsauftrag gegeben. EN > DE und EN > CN. Beide Übersetzungen habe ich "Automatisch" durchgeführt. Also ohne darauf zu achten was da passiert. Die neuen Seiten wurden erzeugt und als Draft angelegt. Korrekt. Ich habe sie nicht publiyiert, damit sie sehen können was da los ist.
Die deutsche Übersetzung hat automatisch
...dev2/product/test-fuer-marcel/?lang=de bekommen. Das ist ok. Der Seitenname wurde übersetzt und der URL so gebildet. Das ist in der Regel perfekt.
Die Chinesische Seite bekam ...product/马塞尔测试/?lang=zh-hans
Das ist nicht was wir brauchen.
...dev2/product/test-for-marcel/?lang=zh-hans wäre richtig.
Was aber noch schlimmer ist, die Seite hat in der Uebersetzung die Einstellungen verloren. Während auf der Englischen Seite die Thumbnails richtig angezeigt werden sind die Thumbnail Filtereinstellungen auf der Deutschen und auf der Chinesischen Seite verloren. Das macht die meiste Arbeit.

August 6, 2019 at 1:19 pm #4347761

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Wolfgang,

ich habe es nun auf "Copy from original language if translation language uses encoded URLs", umgestellt, nun funktioniert es bei manueller sowie automatischer Übersetzung:

Seiten:
hidden link <-> hidden link

Portfolio:
hidden link <-> hidden link

Ich hatte die Einstellung zuvor aktiv, jedoch hat es nur bei Seiten funktioniert, nicht bei Portfolio Einträgen. Hier ist so, wie es aussieht die Wartezeit ein paar Sekunden länger, bis die Übersetzung verfügbar ist (auch bei manuellem Aufruf).

Freundliche Grüße
Marcel

August 7, 2019 at 3:30 pm #4356507

olafM-4

Hallo Marcel. Super. Ein Problem ist gelösst. Es ist ja super, dass es dafür eine Einstellung gibt Da hebn wir alle wieder was gelernt. Da muss man erst mal drauf kommen. Ich habe nun ein Post als Test andgelegt. hidden link
Da sind die URL automatisch so, wie wir das brauchen. Auf Deutsch dann der Seitentitel in der URL und auf Chinesisch der URL von der Ausgangsprache also der URL der englischen Seite. Perfekt.
Das ist aber leider nicht alles. Wie Sie im Test sehen wurden die Link Targets aus der Button Row und die Masonry Filter Settings nicht in die übersetzten Seiten übernommen. Soll wir das in ein neues Ticket schieben?
Und unsere Site meldet: "There is new translated content on this site. You can scan posts and strings to adjust links to point to translated content. Translate Link Targets" Wenn ich das anklicke dann habe ich alle Seiten zerschossen.
Wir sind einen Schritt weiter, aber noch nicht am Ziel. Was tun?
Gruß
Wolfgang

August 7, 2019 at 3:45 pm #4356565

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Wolfgang,

sehr gut! Machen wir daraus bitte ein neues Ticket. Dann können wir dies nun gezielt mit dem Avia Framework debuggen. Sie können dieses daher bitte als erledigt markieren und das neue gerne direkt mir zuweisen.

Freundliche Grüße
Marcel

August 7, 2019 at 4:16 pm #4356741

olafM-4

My issue is resolved now. Thank you! Who would have thought that this problem can be solved through settings.

August 8, 2019 at 8:24 am #4360893

olafM-4

Hi Marcel, the split ticket is now posted as
Home › Support › English Support › Using WPML with ENFLOD Theme. New translated page using ATE does not work
Sorry, spelling error >ENFOLD<
When you have time ... I will go for a week to the beach.