This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Patrick W 11 months, 4 weeks ago.

Assigned support staff: Bruno.

Author Posts
October 13, 2018 at 11:36 pm #2814587

Patrick W

I am trying to:
I have an English/German website and a logo with copy in it. I need to have a different logo appear on the German site than the English.

Link to a page where the issue can be seen:
hidden link

I expected to see:
Logo with German words

Instead, I got:
Logo with English words

October 15, 2018 at 7:42 pm #2818619

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Please, my sincere apologies for the delay in answering.

For the logo, are you using the Elementor image widget? Or are you using the text widget with the "img" HTML tag to add the logo image?

Also, on the WPML > Media translation, did you already add the image to the secondary language? If not, please follow the steps in our documentation and see how to add image in the secondary language: https://wpml.org/documentation/getting-started-guide/media-translation/

If the problem still persists, can you please elaborate a little more so I can better understand? Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit so if you like make use of "upload an image" below the comment area.

Thank you.

October 16, 2018 at 12:37 am #2819001

Patrick W

I am using an Elementor Pro header template. "WPML > Media Translation" is installed and I have a German Language image installed for the logo. I've also tried flushing the cache. Nothing seems to work to get the correct image to present on the German site.

October 16, 2018 at 1:22 am #2819044

Patrick W

I have included admin access and a Link to duplicator package in another related support message.

October 17, 2018 at 3:22 am #2823089

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. I saw the problem you're reporting. I'll test a little more in my testing environment and soon I'll contact you.

Thank you.

October 18, 2018 at 1:48 am #2826125

Patrick W

Any update on this issue?

October 19, 2018 at 7:00 am #2830749

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Sorry for the delay. I'm still testing your site, but this also seems to be a compatibility issue.

You may need to, as on the other topic, switch the header page to the secondary language (using the top bar) and update the image manually using the Elementor interface.

Please, could you follow the steps above and check if the problem persists or if this workaround works?

Thank you.

October 19, 2018 at 6:09 pm #2832804

Patrick W

While this approach worked for URLs it did not work so good for images.

October 23, 2018 at 8:05 am #2841334

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. In this case, the logo images are not being added in the Elementor. Please follow the steps below:

- Click on the Avada > Theme Options
- Click on the "Logo" menu item
- Using the top bar, switch to the Germany language
- On the "Default Logo", select the Germany logo
- Click on the "Save Changes"

Following the steps above, the logo is changed correctly. That's because, even though you added it to Elementor > My Templates, in fact, the logo was added to Avada's options.

Thank you.

October 24, 2018 at 12:15 am #2844248

Patrick W

My issue is resolved now. Thank you!