This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by entiposisI 2 years, 8 months ago.

Assigned support staff: Noman.

Author Posts
November 6, 2017 at 11:34 am #1421678

entiposisI

Hello,
I would like to translate logo image. How can I do that? My site is epirusfarm.gr.

Is there any documentation for that?

Thank you in advance.

November 6, 2017 at 1:01 pm #1421825

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML support. 1. For translating your logo, you can do it from WPML >> String Translations. Here, you need to look for the URL of your logo:

Provided that you have the "WPML String Translation" AddOn installed please follow these steps:
- Go under "WPML -> Theme and plugins localization".
- Make sure that "Translate the theme and plugins using WPML's String Translation and load .mo files as backup" is active.
- Scroll down to "Strings in the theme" and click on "Scan the theme for strings".
- Once you followed the above steps go under "WPML -> String Translation". All strings available for translation should display in the table you see there.

Do you see them? If yes, all you need to do is click on "translations" next to each string you want to translate and enter + save your translations.

Documentation:
https://wpml.org/documentation/getting-started-guide/string-translation/

Thank you

November 6, 2017 at 1:50 pm #1421920

entiposisI

I followed all of your steps but under "WPML -> String Translation" it doesn't appear logo link (hidden link) in order to replace it in english language with hidden link

How else can I make it appear in English?

November 6, 2017 at 2:09 pm #1421941

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Okay, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

✙ Please provide the Debug info in the debug Information box. I have enabled debug info box for your next reply: https://toolset.com/faq/provide-debug-information-faster-support/

Thank you

November 7, 2017 at 5:58 pm #1423610

entiposisI

Please view debug information under Dashboard > Debug Info

November 8, 2017 at 1:25 pm #1424522

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for providing login info. I am working on this issue right now and will get back to you soon with my findings.

Thanks

November 8, 2017 at 2:04 pm #1424601

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hello,

I have performed the below steps to resolve this issue, please check now:
hidden link

1. Deleted logo images for both languages.
2. Renamed and re-added logo images for both languages.
3. Deleted the string translation of logo images for both languages.
4. Re-added the string translation of logo images for both languages. See attached screenshot.

Please note I have updated both the logo image url and the logo Image ID for each logo, because the theme is also using image id in the logo meta key or field.

Thank you

November 9, 2017 at 7:05 am #1425456

entiposisI

Thank you so much!