This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.75 hours from now. Thank you for your understanding.

This topic contains 4 replies, has 2 voices.

Last updated by adrianS-30 2 months ago.

Assigned support staff: Lauren.

Author Posts
August 15, 2019 at 8:22 am

adrianS-30

I try to translate the name/label of a CPT which I created with the Pods plugin.

I made the CPT translatable in the WPML settings.
The English name/label is 'Projects' and when I search for that in the String Translation page, results appear, but after adding German translations the 'Projects' appearances in the German archive page still remain English.
It's the <title> tag in the CPT archive page and the heading 'Post Type Archives: Projects' that I want to translate.
After googling I tried to find something in the 'Translate texts in admin screen' page, but without success.

Can you tell me how I can get this done? Thank you!

August 15, 2019 at 12:36 pm #4400787

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this. Can you please send me a screenshot of where you are seeing the incorrect translation for projects? When I view your project page, I'm not seeing the content on the page, or any archive pages. Perhaps a screenshot will help me better understand what you are trying to translate?

I see that the CPT slug is translated in the URL, so I just want to make sure I am understanding the issue correctly. Thanks for your help.

August 16, 2019 at 2:12 am #4404011

adrianS-30

Sorry, should've sent the link to the German archive: hidden link

I added a screenshot where you can see the occurrences of the English/untranslated CPT's name/label. I want to translate these, so instead of 'Projects' I want 'Projekte' to show.

Thanks!

August 16, 2019 at 3:10 pm #4407219

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for the explanation. I found that in the Pods settings, there was an option to "enable" translation. I then went to Pods -> Components -> Translate and enabled German for the Projects post type. After this, when you go to edit the Pod, you will see the field to enter the label for German. I added Projekte to the label field and now it shows correctly on the frontend.

Please let me know if you need any further assistance and I will be happy to help.

August 18, 2019 at 9:49 am #4411833

adrianS-30

Didn't expect to find it within the Pods plugin, thank you very much!