This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.80 hours from now. Thank you for your understanding.

This topic contains 12 replies, has 3 voices.

Last updated by amelieB-3 5 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
May 10, 2019 at 3:04 pm #3785969

amelieB-3

Hello, I am working on a website and translating it. For now it's still a coming soon page on the front end. I am not using the new editor because i don't really like how it splits the content then i am using the old one. With the theme i am using, i get a bunch of translations needs that i would like to automatize (see screenshot), it's the builder options. Is there a way to translate them all at once (i dont really care if "left" "cover" or else is not translated. I could eventually give you access to the website if you wish, the url is hidden link.
I would greatly appreciate to have only page content and tour content (already translated the strings i need for the rest, footer and else). Theme is travel tour, said compatible with WPML.
Thank you

May 10, 2019 at 6:19 pm #3787411

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

From the screenshots, it looks like the custom fields. So maybe the values will differ in the Pages. But we can copy all the values from the original language post/page. Please click on *Copy from original* button of WPML Classic Translation Editor to copy the values from the original language Post/Page. Check the attached image for more details.

I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

May 11, 2019 at 7:44 am #3789879
amelieB-3

Hi, I also have a problem with one page: "a propos", I translated it but it doesnt display on the page in English listing, a suggestion? Thank you 🙂

New threads created by Shekhar Bhandari and linked to this one are listed below:

https://wpml.org/forums/topic/translated-page-not-showing-in-dashboard-pages/

May 13, 2019 at 5:01 am #3795187

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Since Bigul is off for a few days, I will replace him here in the forum. I hope this is OK for you 🙂

This is a compatibility issue that I was able to figure out on one of my previous tickets, I escalated it and the compatibility team back then provided a workaround for this so would you mind trying the same workaround from the below link and let me know if this helps?

https://wpml.org/forums/topic/strings-and-tags-appear-in-the-advanced-editor/#post-3507479

NOTE:

+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!). You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose. See: http://wordpress.org/plugins/duplicator/

Let me know if this helps.

Thanks

May 14, 2019 at 12:46 pm #3806913

amelieB-3

Hello, I tried your code and it says "invalid XML format : Element 'custom-fields-texts': No matching global declaration available for the validation root. " so I guess it does not work....other ideas? thank you

May 15, 2019 at 3:40 am #3811957

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I noticed I forget to add <wpml-config> tag here, so the updated code is

<wpml-config>
    <custom-fields-texts>
        <key name="gdlr-core-page-builder">
            <key name="*">
                <key name="value">
                    <key name="title"/>
                    <key name="caption"/></key>
                <key name="items">
                    <key name="*">
                        <key name="value">
                            <key name="title"/>
                            <key name="caption"/></key>
                    </key>
                </key>
            </key>
        </key>
    </custom-fields-texts>
</wpml-config>

Could you please try it now and let me know if this helps?

Thanks

May 15, 2019 at 6:33 am #3812601

amelieB-3

Hello, thank you for your reply? I Tried and implanted your code, it was successful. I did refresh the page as well. However, when trying to translate a page, I still have custom fields that display and do not have the main text displayed. I found a hack but it's not so good: translate all the fields available and then go to the English pages and hard core modify the pages so they can be translated. I am still wasting a lot of time though. Do you have any other ideas? Thank you so much for your patience ! Have a good day 🙂 PS: I checked before buying the theme, it was said to be compatible with WPML

May 15, 2019 at 6:39 am #3812615

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

However, when trying to translate a page, I still have custom fields that display and do not have the main text displayed. I found a hack but it's not so good: translate all the fields available and then go to the English pages and hardcore modify the pages so they can be translated.

I am not exactly sure about the steps you are mentioned, is it possible for you to add few screenshots showing these steps? Also, a page link where I can see the issue will also be helpful.

Thanks

May 15, 2019 at 7:05 am #3812849

amelieB-3

I made a screenshot of a page that i have not yet translated, i still see custom fields and would like them to disappear. Also, I only see titles to translate and not the entire text. So the way around I found was to translate everything (using the copy all the fields) and then when the page is said to be fully translated (100%), I go to the English page listing and modify it directly cause I cannot access the text fields directly from the WPML editor. I can provide access if you wish, it is the same as the about page issue.... you can see the website @ sun-tour.fr. I might have unchecked a part in the WPML settings, maybe the issue comes from there? If you need access, no problem but in private of course....

May 15, 2019 at 8:30 am #3813633

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

ou can see the website @ sun-tour.fr. I might have unchecked a part in the WPML settings, maybe the issue comes from there? If you need access, no problem but in private of course..

Isn't the login details the same you provided before?

I have enabled the private form for the next reply so please provide the details if it's new.

Also, provide the page link.

Thanks

May 15, 2019 at 9:59 am #3814679

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Please follow the below steps to fix the issue:

- Go to the Page editor
- Go to Multilingual content setup
- Mark the "gdlr-core-page-option" as a copy
- Further, I make a slightly change in the config file provided, you can check it on your site, I added a new line <key name="content"/>

For new pages, it will work automatically, for the previous page, you will need to mark the page as translation complete, update once to apply the settings.

Let me know if this helps.

Thanks

May 15, 2019 at 10:33 am #3814949

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Let me know if that helps.

Thanks

May 15, 2019 at 12:05 pm #3816099

amelieB-3

Issue fixed thank you 🙂