Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by doronN 2 years, 11 months ago.

Assigned support staff: Bigul.

Author Posts
January 3, 2017 at 10:04 am #1173169

doronN

I am trying to: create different sidebars for each language in my site

URL of (my) website where problem appears: hidden link

I'm using this guide -

https://wpml.org/2016/02/content-aware-sidebars-wpml/

to create a sidebar for each language. when I go to WPML > Translation management > Multilingual Content Setup, and scroll down to the Custom posts section, the “translate” options for “Condition Groups” and “Sidebars" are disabled.
Some CPT you can change the option, but in some don't (including the“Condition Groups” and “Sidebars" )

I found this post https://wpml.org/forums/topic/translation-options-for-custom-posts-have-got-disabled/ and followed the instructions there - and it didn't work.

my wpml-config.xml file looks like this:

<wpml-config>
<admin-texts>
<key name="ARMONIOSO_PANEL">
<key name="header_banner_editor" />
<key name="blog_homepage_welcome_block_content" />
<key name="footer_copyright_editor" />
<key name="blog_homepage_editorspick_posts_title" />
<key name="blog_homepage_editorspick_posts_subtitle" />
<key name="footer_instagram_title" />
<key name="footer_instagram_subtitle" />
</key>
</admin-texts>
</wpml-config>

January 3, 2017 at 2:22 pm #1173498

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi ,

Thank you for contacting the WPML support. We are happy to help you.

Please let me know the following for tracking the issue.

1) Confirm you having a wpml-config file in *Content Aware Sidebars* folder

2) Please switch to your parent theme or default 2017 theme(after a site backup) and check you are still having the issues

3) Please add the following code in wp-config.php file of your site to enable WordPress to debug mode. It will create a *debug.log* file in *wp-content* folder. Visit WPML>>Translation Management>>Mutlilingual Content setup and check you are getting any errors or warnings related to WPML in the log file.

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );
 
// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

Please check following links to read more about debugging with WordPress.

https://codex.wordpress.org/Debugging_in_WordPress

--
With Regards

Bigul

January 3, 2017 at 3:25 pm #1173573

doronN

1. Yes - I have wpml-config file in *Content Aware Sidebars* folder

<wpml-config>
    <custom-fields>
        <custom-field action="ignore">_cas_post_type</custom-field>
        <custom-field action="ignore">_cas_taxonomy</custom-field>
    </custom-fields>
    <custom-types>
        <custom-type translate="0">sidebar</custom-type>
        <custom-type translate="0">condition_group</custom-type>
    </custom-types>
</wpml-config>

2.switched to my parent theme and default 2017 theme - issue persists - still can't edit.

3. Added the code - I see no /wp-content/debug.log file.

January 4, 2017 at 5:55 am #1173947

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thank you for the updates. For your information, the "Condition Groups" and "Sidebars" are disabled because of your WPML configuration in *Content Aware Sidebars* folder.

Please try with the following code after a backup and let me know your feedback.

<wpml-config>
    <custom-fields>
        <custom-field action="ignore">_cas_post_type</custom-field>
        <custom-field action="ignore">_cas_taxonomy</custom-field>
    </custom-fields>
    <custom-types>
        <custom-type translate="1">sidebar</custom-type>
        <custom-type translate="1">condition_group</custom-type>
    </custom-types>
</wpml-config>

Please check the following tutorial to learn more about the WPML Language configuration files.

https://wpml.org/documentation/support/language-configuration-files/

--
With Regards

Bigul

January 4, 2017 at 7:55 am #1174001

doronN

Hey Bigul
Thanks for you help!
The selection is still disabled - but changing the wpml config file set it to "translet". - so in that aspect is solved the problem.
The question remains - why the selection is disabled?
And - what will happen when I'll update the "content aware sidebar" - will it override the wpml conf file?

January 4, 2017 at 1:03 pm #1174298

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thank you for the confirmation. I would like to confirm one thing. Please download the latest version of *Content Aware Sidebars* plugin and make sure it having a *wpml-config.xml* with similar settings or not.

Please check and let me know your feedback.

--
With Regards

Bigul

January 7, 2017 at 10:22 am #1176567

doronN

I already had the newest version of the *Content Aware Sidebars* plugin.
I went with another solution for translating sidebars - This had to many problems.

Tnhanks