This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 2 voices.

Last updated by tomv-15 3 weeks, 6 days ago.

Assigned support staff: Raja Mohammed.

Author Posts
August 21, 2019 at 8:35 pm #4434969

tomv-15

I am trying to: import with WP all import

Link to a page where the issue can be seen:hidden link

I expected to see: languages switcher

Instead, I got: no language switcher

Also: in woocommerce multilingual German is not set as a translation from the Dutch product

August 22, 2019 at 6:20 am #4436567

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi There,

I am unable to reproduce the issue while checking your site. I can see the language switcher at the topbar on the page hidden link, I have attached a screenshot for further reference.

However, it seems like the product is not translated and hence I am redirected to the homepage when trying to change the language of the product

If I understand your last request correctly, Do you mean the German and Dutch products are not in sync? Maybe they are created as unrelated individual products.

If that is the case then there is some problem in the import, Could you please let me know the steps you followed and documentation referred to complete the import process.

Related documentation: hidden link

Please let me know the details to help you better.

Kind regards
Raja

August 22, 2019 at 9:39 am #4438055

tomv-15

Hi Raja,

that's true, but it links to the homepage (when there is no translation it does this automatically). The products are not translations from each other i guess. Thanks

August 22, 2019 at 1:49 pm #4439887

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

It seems like you might need to re-run the import process.

Maybe you can try something which might help.
Before you proceed Backup your site and database
- Goto WPML > Support > Troubleshooting (check attached screenshot)
- On the troubleshooting page click on the below
- Select "Product" and Hit "Synchronize posts taxonomies"
- Clear cache with WPML
- Remove Ghost entires
- Set langauge information
- Fix element_type collation

Check if that resolves your issue.

Kind regards
Raja

August 22, 2019 at 2:01 pm #4440047

tomv-15

Hi Raja,

I did this yesterday also. Both languages are correctly imported, but the products don't seem match. Thanks

August 22, 2019 at 2:01 pm #4440051

tomv-15

Is there no way to merge them afterwards for now?

August 22, 2019 at 2:12 pm #4440131

tomv-15

Because there are exacly the same German and Nederlands products, with the same connector etc. So it should work. They are just not connected.

August 22, 2019 at 8:22 pm #4442795

tomv-15

Someone there maybe?

August 22, 2019 at 9:01 pm #4442905

tomv-15

https://wpml.org/forums/topic/wc-products-dont-get-linked-between-languages-when-imported-with-wp-all-import/page/3/

is this the same problem?

August 22, 2019 at 9:24 pm #4442983

tomv-15

https://wpml.org/forums/topic/how-to-import-products-in-two-different-languages/

August 22, 2019 at 10:22 pm #4443085

tomv-15

Hi Raja,

Can you eloborate on the connector? I guess something goes wrong there. We have used SKU as well as another extra connector. But when you choose the unique identifier in the fourth step and you let WP All import find the connectors: what should be in this input field? Only the SKU? Another connector? Multiple?

Multiple people with experience have tried to follow the documentation now. If this function does not work then i would like to know, because this starts to take a lot of time. Thanks!

August 23, 2019 at 7:42 am #4444871

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Products usually have the same SKU in both languages. you can just use that field as a connector field, no multiple connectors required.

Try importing with the SKU as a connector, Let me know the results, Let me know if you are stuck. I can test the issue with an import copy on my local or sandbox site.

Kind regards
Raja

August 23, 2019 at 9:49 am #4445753

tomv-15

Yes can you please do that? We have tried it so many times now. The csv files we are using are

1. Items_for_WooCommerce_SHCN_NL
2. Items_for_WooCommerce_SHCN_DE

Thanks

August 23, 2019 at 9:50 am #4445755

tomv-15

You can delete all products if you want on the live site.

August 23, 2019 at 2:03 pm #4447997

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I am afraid I don't have access to your site to perform these operations.

I just saw you have created another ticket, it seems Lauren is helping you with it already.