This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by ioannisS-7 2 weeks, 6 days ago.

Assigned support staff: Mihai Apetrei.

Author Posts
September 23, 2019 at 8:39 am #4621675

ioannisS-7

Hello ,
I have already contact with the theme support but they told me to ask u for help.
I am trying to translate properties from the frontend dashboard but there is no option to do that.
Is there any way to do the translation from the frontend?
Thanks

September 23, 2019 at 8:40 pm #4626615

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

The way to translate those strings really depends on how they have been implemented in the code.

1. Can you please let me know if you tried to go to WPML > String Translation and search for any of the words in those sentences?

Here is some very helpful documentation on how to use the String Translation plugin:
https://wpml.org/documentation/getting-started-guide/string-translation/

If it's not there, it could help if you scan the plugin/theme that's generating the strings and then go back to WPML > String Translation and see if the strings show up:
https://wpml.org/documentation/getting-started-guide/theme-localization/

2. If you can't find it inside the WPML > String Translation, it might be added as admin text.

This should be the normal process to translate admin texts:
https://wpml.org/documentation/getting-started-guide/translating-theme-options/

If you still can't find it, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

In order to be able to help you faster, can you also please paste your WPML Debug information in the Debug information field?
http://wpml.org/faq/provide-debug-information-faster-support/

I will be waiting for your response.

Kind regards,
Mihai Apetrei

September 25, 2019 at 10:51 am #4637985

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the explanation.

There are a few things that I need you to do:

1. Create a full website backup first

2. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased as the minimum requirement for WPML is 128Mb WP Memory Limit: https://wpml.org/home/minimum-requirements/

❌ Very important: please make a backup of your site (files & database) before following any of the upcoming steps ❌

Please add this to your wp-config.php file to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy blogging. */

These settings can be limited directly by your hosting provider, so, if that’s the case, I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

3. Please go here (hidden link) and update all the plugins to the latest version.

Please let me know when that's done.

Kind regards,
Mihai Apetrei

September 25, 2019 at 3:15 pm #4640359

ioannisS-7

Hello again!
I have made the changes you need.Please inform me when you are ok.
Thanks again!

September 25, 2019 at 4:17 pm #4641073

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the confirmation.

I will spend more time on this and I will get back to you as soon as I have more feedback.

I will leave the ticket assigned to myself for the moment.

Kind regards,
Mihai

September 25, 2019 at 4:17 pm #4641075

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

PS: Just a note that I am at the end of my shift at the moment and I will be able to get back to you tomorrow.

September 26, 2019 at 4:02 pm #4648605

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for your patience.

First of all, I want to let you know that it's a known fact that the Houzez theme has compatibility issues with WPML, as you can see mentioned in the link below:
https://wpml.org/theme/houzez/

This means that it's not fully compatible with WPML at the moment.

However, regarding the situation that we are handling in this ticket, the way to translate the properties would be a little different:

1. Go to a property's edit page (like this one for example: hidden link)

2. If you scroll down a bit, you will get to a section called "Multilingual Content Setup" - that's where you will find a lot of custom taxonomies and custom fields that are registered and that are coming with this theme and before you translate this specific section, you need to make sure that all the custom fields that you want to translate are having the radio box checked to the "Translate" (not copy/copy once/don't translate) option - some of them are set to "Don't translate".

3. After you check the boxes and save the fields, at the top on the right side you will find the "Language" section where you can translate the property in either English, Russian or Spanish so you can click "+" on the one that you want to translate.

Instead of translating everything, you could also duplicate a translation into another language by using the procedure below:
https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/using-content-duplication/

To answer your other question:
We don't have an option for our products that would allow front-end translation at the moment so the only way to translate content is from the back-end by following the procedure above.

I hope that you will find this information helpful and please let me know if you have any further questions regarding this topic.

I will be waiting for your response.

Kind regards,
Mihai

September 26, 2019 at 7:14 pm #4649909

ioannisS-7

Hi again and thanks for your reply,
Well we have found that solution from the first time but we hope to find a better solution for our client, because now the client has to create a new listing from the frontend , then must enter the backend to duplicate the property to another lang and then enter again at the frontend to edit the duplicated property at the right lang....
Thats why we wanted your help...if it is not possible that it's ok...

September 28, 2019 at 10:29 am #4658223

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I would have loved to be able to offer another alternative but unfortunately, that is the only proper way to do it at the moment.

Sometimes there are more ways things can be done but regarding the Houzez theme, this is the only way at the moment.

Kind regards,
Mihai

October 1, 2019 at 9:25 am #4670187

ioannisS-7

My issue is resolved now. Thank you!