Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 3.08 hours from now. Thank you for your understanding.

This topic contains 14 replies, has 3 voices.

Last updated by Riffaz 1 year, 8 months ago.

Assigned support staff: Riffaz.

Author Posts
November 29, 2018 at 1:15 am #2950062

karenK-9

My theme is based on Visual composer however when I click to translate the page not all blocks are there to translate.

November 29, 2018 at 1:19 am #2950064

karenK-9

check this pages for translate and see which part is not translated. I have this shit (i'm sorry cant find another word when i work with your plugin) on each page.

hidden link

November 29, 2018 at 9:08 pm #2953952

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi Karen, I'll be happy to help you with this. Can you please tell me which blocks are not translatable? All of the content on your page is in English and there is no other language showing in the drop down language switcher to change to, so I can't see which sections are not translating.

It is likely that the shortcodes are missing from the wpml-config.xml file, or if there are theme shortcodes you are using for the elements. Can you please tell me what element type(s) you are using for these sections?

Also, please update to the latest versions of WPML plugins, as I can see from the debug information that you are not using the latest version.

November 29, 2018 at 9:10 pm #2953955

karenK-9

Hi Lauren,

happy to chat with you.
This is my staging website so I can test before trying on the production one.

How do I know which shortcodes are not avaliable and add them?
I can give you the access if you need?

Thanks

November 29, 2018 at 9:21 pm #2953980

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

You can see all of the shortcodes if you switch to the classic mode. So, look for the section that is missing from the translation editor and see which shortcode it is wrapped in. Then, you can go to WPML -> Settings -> Custom XML Configuration and add the shortcode there.

Once it is added, make any small change or just update the original page. Then, try translating the page and the missing element should now be in the translation editor. You can follow the documentation here on how to add it to the custom xml configuration: https://wpml.org/documentation/support/language-configuration-files/

If you need further assistance with this, you can send me credentials so that I can take a look at your site. I have marked the next reply as private.

November 30, 2018 at 3:12 pm #2956555

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sharing the video. I added some shortcodes to the custom xml configuration but only some of them are appearing on the translation editor.

THe problem is coming from a conflict with your theme, which is not compatible with WPML. You can check the list of compatible themes here: https://wpml.org/documentation/theme-compatibility/

Compatible themes and plugins should include a wpml-config.xml file in the folders that registers all of the shortcodes for translation. As you can see when you edit the page in classic mode, the theme elements start with nd_options. The standard Visual Composer elements show up in the translation editor, but not these custom theme shortcodes.

In order to make the theme and WPML work well, we will likely need to escalate this to our compatibility team so that they can get in touch with the author. To test this, I have set up a staging site. Can you please install your theme there so that I can try and reproduce this issue in a clean install?

Here is the access for the test site:
Login: hidden link
Username: demo
Password: 4Mo3s2TPYfp1

Once you have installed the theme, let me know and I will continue troubleshooting.

November 30, 2018 at 6:36 pm #2957194

karenK-9

Hi Lauren,

The theme is advertised to be comparable with your plugin.

1. I Installed the theme on your hosting. I see there is a plugin ND Shortcodes maybe this is the one we need to use?

2. Also I found this in the documentation hidden link

3. I have a question. if it won't work out can I use manual translation (duplicate pages)

I hope you can help mw figure out how to translate the theme

thanks

December 3, 2018 at 12:18 pm #2962112

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Lauren is in her vacation now and I will be assisting you till she comes back.

After I set up the WPML I see that the almost all of the theme posts types or pages are NOT translatable: hidden link
Please make them translatable first.

And then change the translation method to the manual here : hidden link
Then duplicate or translate using + sign in pages or anywhere else: hidden link
You can translate independently now: https://wpml.org/documentation/translating-your-contents/page-builders/translating-content-created-with-page-builders-using-manual-translation/

Let me know the results, please.

Regards,

December 3, 2018 at 5:31 pm #2963656

karenK-9

Hi.

I am confused again.

The developer said that the theme is comparable. I found this in the docs hidden link
Hope that helps. I don't understand anything there. You can search for other articles.

1. why do I need to change translation method to Manual? When I do this it's not working when I use + icon to translate.
2. I switched to enable on Production however the page still not showing missing blocks.
3. I asked a question you did not answer. If nothing will work out can I use manual translation (duplicate pages) instead of + icon?

P.S. I'd appreciate you try on my site first before answering, otherwise i get confused even more.

please help asap

December 4, 2018 at 4:48 pm #2967422

karenK-9

I didn't get a response from you. I need to fix this asap so cooperate with me.

This is an answer from the theme developder
"the theme is compatible with the plugin, you can check our demo made with WPML as proof.
hidden link "

December 5, 2018 at 11:59 am #2969882

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

1. why do I need to change translation method to Manual? When I do this it's not working when I use + icon to translate.
- because when you do that your site won't use translation editor.
- you can translate independently.

3. I asked a question you did not answer. If nothing will work out can I use manual translation (duplicate pages) instead of + icon?
- yes, you can.
- just duplicate like this : hidden link
- and then use this option : hidden link
- now switch to backend editor: hidden link
- translate as you want.

2. I switched to enable on Production however the page still not showing missing blocks.
- when you follow the steps above this won't be an issue. I tested in sandbox.

I didn't get a response from you. I need to fix this asap so cooperate with me.
- when you write again before you get the reply your ticket will go to the end of the queue.
- we reply in queue order.

Regards,

December 5, 2018 at 6:03 pm #2971201

karenK-9

Hi there,

1. Why I cannot use the translation editor if the theme developer told me the theme is comparable? I am fine to translate with Manual editor, however, I just want to make sure this option is also a good one.

2. I changed to Manual in the settings, the added a mark on Duplicate section, the clicked on the button Duplicate that appeared right away but I don't see this screenshot hidden link Here is what I see hidden link

3. If I do Manual, do I need to do any thing with those options which I enabled several days ago:
hidden link
hidden link
hidden link

4. When I enable Manual translation this is what I see after hidden link

Thank you for your help

December 6, 2018 at 11:42 am #2973627

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

2. click on 'translate independently' and proceed
3. no need to change anything
4. you can ignore this or You can hide this notice using CSS, but please keep in mind that this will also hide all missing requirement notices. To hide it please place the following CSS in your custom CSS file:

.is-dismissible notice otgs-notice {
display: none;
}

Regards,

December 7, 2018 at 7:24 am #2976845

karenK-9

manual translations are not working either. I dont know what to do.
here is a video that you can see when I change the language there is a dynamic section that are not shows any more: hidden link

In addition if that's a dynamic section I have a feeling I won't be able to change a link to the translated content.

The developer told me that theme is FULLY compartable with your plugin. He gave me a link. I told you about that. You didn't even reply about that in two above messages.

I am stuck with this theme and plugin.

December 10, 2018 at 11:48 am #2983828

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Sorry for the delay. We do not work on weekends.

Please provide a copy of your site to debug this closely and locally.
In case, if needed, I can check with second tier support as well.

Please refer : https://wpml.org/faq/provide-supporters-copy-site/

Regards,

The topic ‘[Closed] translate site 1 month of struggling (hate your plugin)’ is closed to new replies.