This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

I'm trying to translate the " Enter the amount due" string of the YITH WooCommerce Name Your Price plugin.

Solution:

I've found the string in the Admin Texts section. But I couldn't move it to the String Translation section. So I've registered it in WPML -> Settings -> Custom XML Configuration (tab). In this section, I've added the following code.

<wpml-config>
    <admin-texts>
        <key name="ywcnp_button_loop_label"/>
    </admin-texts>
</wpml-config>

And now the string is available for translation in the String Translation section.

Relevant Documentation:

https://docs.yithemes.com/yith-woocommerce-name-your-price/localization/wpml-localization

https://wpml.org/?page_id=892558

https://wpml.org/documentation/support/language-configuration-files/

This topic contains 2 replies, has 2 voices.

Last updated by lexC 1 month, 2 weeks ago.

Assigned support staff: Itamar.

Author Posts
August 27, 2019 at 8:22 am

lexC

Tell us what you are trying to do?

Our site has 2 languages: EN and Dutch.

On page hidden link we can not translate "Enter the Amount due". This is a setting of Woocommerce. We cannot find this in overview String Translation.

Please your help?

August 27, 2019 at 10:08 am
August 27, 2019 at 10:15 am #4464943

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

This ticket has been inactive for quite a while, so I'm transforming this chat into a support ticket.

I've fixed the issue on your site. Now the 'Enter the amount due' string is translated into Dutch. Please see the attached screenshot amount-due-nl.jpg.

I've found the string in the Admin Texts section. But I couldn't move it to the String Translation section. So I've registered it in WPML -> Settings -> Custom XML Configuration (tab). In this section, I've added the following code.

<wpml-config>
    <admin-texts>
        <key name="ywcnp_button_loop_label"/>
    </admin-texts>
</wpml-config>

And now the string is available for translation in the String Translation section. Please see the attached screenshot amount-due-inst.jpg

Can you please confirm that this issue is solved now and mark this ticket as resolved?

Thanks,
Itamar.

August 27, 2019 at 10:39 am #4465263

lexC

My issue is resolved now. Thank you!