This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by maxL-15 1 month, 3 weeks ago.

Assigned support staff: Lauren.

Author Posts
August 16, 2019 at 7:22 pm #4407971

maxL-15

at the bottom of hidden link is the text 'Share This Article', I translated these words in all the languages in String translation of WPML, but it stays the same on the frontend. What's going wrong?

August 16, 2019 at 7:26 pm #4407977

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this. Can you tell me where that text is coming from? Is this a plugin or widget that you are using? If so, do you have the ability to edit that title in the plugin settings?

If you do, it may be that the string is stored in the admin texts. Can you please go to WPML > String Translation and scroll down to the bottom of the page and click on the link "Translate texts in admin screens »". Then, scroll through that page and see if you find the the string. If so, tick the checkbox and click Apply to add it to the String Translation table. Now you can go back to WPML > String Translation and you should see the string added there.

August 16, 2019 at 7:34 pm #4407983

maxL-15

I honestly don't know where that function to share the product is coming from. I really don't know if it is a plugin or a theme option.

I can't find the option you are supposing to me.

August 16, 2019 at 8:35 pm #4408133

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

OKay, we will need to figure out where it is coming from in order to figure out how to translate it. If you go to your theme options, do you see anywhere that you can enable sharing?

If you edit a page/product, do you see the option anywhere there to enable sharing?

August 16, 2019 at 8:37 pm #4408137

maxL-15

Both no 🙁

How can I activate the WPML editor for pages again?

August 16, 2019 at 9:25 pm #4408217

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Maybe we can find out this way. Make a backup of your site first, then deactivate any non WPML plugins and temporarily switch to a default theme. Does the "share this article" disappear? If so, activate first your theme and see if it comes back. If not, then activate the plugins one at a time until it does come back, and then we will know where it is coming from.

You can activate the WPML editor in the page edit screen. Edit the original page and in the languages box, there is a switch to enable the WPML translation editor.

August 27, 2019 at 7:55 am #4463497

maxL-15

My issue is resolved now. Thank you!