This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 5.64 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem:
I am trying to add some strings from the admin texts to String Translation, but they don't show up in the table after clicking Apply.

Solution:
I added the following to WPML -> Settings -> Custom XML Configuration:

<wpml-config>
    <admin-texts>
        <key name="theme_mods_hello-theme-child-master">
            <key name="custom_logo" /></key>
    </admin-texts>
</wpml-config>

Now, when you go to WPML -> String Translation, you can see the logo available for translation.

This topic contains 7 replies, has 3 voices.

Last updated by evgenyE 1 month, 2 weeks ago.

Assigned support staff: Lauren.

Author Posts
August 27, 2019 at 12:48 am #4461807

evgenyE

I am trying to:
translate logo image in child theme
found it on "translate texts in admin screens" page
select the string and save (apply, waiting for "data saved" message)
>>> if I reload the page - the selected string isn't selected and no strings to translate in the table.

Link to a page where the issue can be seen:
in backend, (the theme with the problem isn't active)

I expected to see:
String for translation (for now it is working with regular theme (elementor hello) but not with child theme I tried to install).

Instead, I got:
>>> if I reload the page - the selected string isn't selected and no strings to translate in the table.

August 27, 2019 at 7:50 am #4463463

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

you mentioned that the string translation is not working with your child theme , is this for all Strings or just the admin screens page not saving the selection ?

if possible please let me know which admin string you are trying to add so i can find it in the admin screens and try to add it for you using the custom config area within WPML->Settings

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

August 27, 2019 at 7:53 pm #4469533

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi there, Bobby is off for a few days so I'm stepping in to help out. I hope that's okay.

I added the following to WPML -> Settings -> Custom XML Configuration:

<wpml-config>
    <admin-texts>
        <key name="theme_mods_hello-theme-child-master">
            <key name="custom_logo" /></key>
    </admin-texts>
</wpml-config>

Now, when you go to WPML -> String Translation, you can see the logo available for translation. Please let me know if you need any further assistance and I will be happy to help.

August 29, 2019 at 5:38 pm #4482923

evgenyE

Thanks a lot, it worked. May be you have same magic lines for 'translating" the side of accessibility button? I can't find something related in strings..

August 29, 2019 at 6:14 pm #4482965

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I can certainly try 🙂 Can you tell me where I can find this button on the frontend of the site, and how you add it on the backend?

August 30, 2019 at 5:44 pm #4488627

evgenyE

It called One Click Accessibility plugin and the button - on every page on the site. I need it on the right side in English version.. There are settings in theme Customize area - for the button. Thanks a lot for your assistance!

August 30, 2019 at 6:10 pm #4488743

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for clarifying. I found the string in the admin texts, added it to string translation and translated it to "right" for English. Looks like it is aligned correctly now.

Please let me know if you need any further assistance and I will be happy to help.

August 30, 2019 at 10:30 pm #4489353

evgenyE

It's perfect support! My issue is resolved now. Thank you a lot!