This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: After translating a string from the comment field, the string is not translated.

Solution: On the WPML > Strint translation, be sure that you have selected the "Translate is complete" option.

Relevant Documentation: https://wpml.org/documentation/getting-started-guide/string-translation/

This topic contains 5 replies, has 2 voices.

Last updated by toniF-2 1 year, 12 months ago.

Assigned support staff: Bruno.

Author Posts
October 18, 2017 at 9:56 am #1404464

toniF-2

Hi

I need to translate the Name* field of the form that appears in the posts, attached screenshot. I have translated the rest of the fields but this one can't be found in the string translation

King regards
Toni Fornés

October 19, 2017 at 4:57 pm #1406261

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you for contacting us.

How is this form being created? Are you using GravityForms plugin, Contact Form 7 plugin, or are you using any custom plugin/code?

Also, please, what is the version of WPML and WP are you using? I would like to know more about your installation. Can you please provide your WPML Debug information in the debug field below? http://wpml.org/faq/provide-debug-information-faster-support/

Thank you.

October 19, 2017 at 5:05 pm #1406272

toniF-2

It's the comment form in the posts. I have not used contact form 7 or gravity forms. I'm sending you the debug info.

October 20, 2017 at 11:41 am #1407020

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. Maybe these strings that are on your theme are not set to be translatable.

I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

*** Please, can I install the Duplicator plugin ( https://wordpress.org/plugins/duplicator/ ) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

October 25, 2017 at 1:36 pm #1411405

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi Toni,

Thank you. I fixed your site. To fix this field, I followed two steps:

- On the WPML > String Translation, I selected the "Translate is complete" option so that the string was saved correctly;
- On the W3 Total Cache, I've cleared the cache of your site.

Please, could you check if the string is displaying correctly?

Thank you.

October 25, 2017 at 1:48 pm #1411431

toniF-2

thank you very mutch!