This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Elementor not copying layout options when using Astra theme Solution: WPML -> Settings -> Custom Fields Translation -> and find these custom fields and set them in the same way I did - to "Copy". Make sure to set these 8 custom fields (there may be more from other plugins, but you can ignore these) to "copy", click "Save" and then open the original page (home page) and simply click update, so that the translation gets these values.

See image. Relevant Documentation: https://wpml.org/forums/topic/translate-the-home-page-page-layout-has-been-changed/#post-4307247

Tagged: 

This topic contains 11 replies, has 2 voices.

Last updated by Bruno Kos 2 months, 1 week ago.

Assigned support staff: Bruno Kos.

Author Posts
July 17, 2019 at 3:50 am #4225695

vishalit

I am trying to: Translate the home page, page layout has been changed

Link to a page where the issue can be seen:hidden link

I expected to see:

Instead, I got:layout changed

July 17, 2019 at 8:15 am #4227193

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

In order to debug this issue further quickly, would you be willing to provide me with temporary WordPress admin username so I could investigate the issue directly? I have marked your next reply private so you can safely add this information.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please make a full backup of your site before sharing this info!

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup.

Regards,
Bruno Kos

July 22, 2019 at 8:39 am #4254925

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you tell me if you're using a combination of Beaver builder and Elementor site? Since these are both visual builders, it would make sense to disable one if another one is used.

As for the issue, when I open:
hidden link

It doesn't seem that these templates have been translated into other languages?
https://wpml.org/documentation/plugins-compatibility/elementor/#translate-elementor-templates

Regards,
Bruno Kos

July 25, 2019 at 3:46 am #4279015

vishalit

home page layout still changing .
not resolved

July 25, 2019 at 8:40 am #4280887

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

It seems like that the temporary login is no longer working. Can I ask you the following then? In order to debug this issue , can you install Duplicator plugin and create package so that I can try this on my localhost and possibly escalate further to 2nd tier?

https://wpml.org/faq/provide-supporters-copy-site/

Let me know if this is OK with you.

If yes, I will need WordPress admin username and password so I could download those packages. I have marked your next reply private so you can safely add this information.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/
Please make a full backup of your site before sharing this info!

Regards,
Bruno Kos

July 30, 2019 at 11:36 am #4307247

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you go to:
WPML -> Settings -> Custom Fields Translation -> and find these custom fields and set them in the same way I did - to "Copy". Make sure to set these 8 custom fields (there may be more from other plugins, but you can ignore these) to "copy", click "Save" and then open the original page (home page) and simply click update, so that the translation gets these values.

I tried this and it worked on my localhost (see image).

Regards,
Bruno Kos

July 31, 2019 at 7:46 am #4312461

vishalit

I am still facing same problem

July 31, 2019 at 8:44 am #4313001

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Is it possible for you to grant me wp-admin access once again, so that I check this directly? Because I have no other suggestions at this point, especially since I was able to got this resolved all my localhost.

I have marked your next reply private so you can safely add this information.

Regards,
Bruno Kos

August 1, 2019 at 6:57 am #4319115

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Using this login, I am unable to view WPML settings. Can you make me site administrator perhaps?

Regards,
Bruno Kos

August 1, 2019 at 7:31 am #4319273

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

How about now? It seems correct on my pc.

Regards,
Bruno Kos

August 1, 2019 at 7:44 am #4319425

vishalit

hi,
finally.delighted
kudos to your patience
thanks alot.

August 1, 2019 at 8:32 am #4319879

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Great to hear this - marking this thread as resolved!

Regards,
Bruno Kos