This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The client is using the "User Profiles Made Easy" plugin and can't find out how to translate specific strings.

Solution: Client solved it this way:

"It does not seem to be a way to translate UPME using WPML, but it seems I found a way out with a couple of workarounds:

1) creating new custom fields only for those needing to be translated (as Geographic Area, or Linguistic services) and leave those in which values are unique, as Name, Email, etc. A user will found in his admin panel both fields to fill in.

2) In Upme settings there is no way to set "profile page" e "member list page" in English, the only trick is using same permalink for both languages and works well."

This topic contains 18 replies, has 2 voices.

Last updated by Marzia 5 months, 1 week ago.

Assigned support staff: Mihai Apetrei.

Author Posts
May 8, 2019 at 2:47 pm #3767895

Marzia

I'm trying to translate strings related to "User profiles made easy" (Upme). They are custom fields values set in some checkboxes
This is the page:
hidden link
Values are, for example, in "Services", and "Specialization" in any user profile listed in the page. Users in their own admin screen can select those strings flagging a checkbox list.
I cannot find anywhere in String Translation those strings.
Please help! thank you!

May 8, 2019 at 3:12 pm #3768329

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

If you can't find the strings inside WPML > String Translation, they might be added as an admin text.

This should be the normal process to translate admin texts:
https://wpml.org/documentation/getting-started-guide/translating-theme-options/

You need to go to WPML > String Translation > Translate text in admin screens > and then search for the strings there (what I usually do is after I get there, I click "View page source" in my browser and I search inside the page code for one of the strings just to see if it is there, because usually the strings can be found under specific tabs that you have to click and open so I first want to look inside the code of the page to make sure I'm not wasting my time clicking and opening tabs).

If you can't find them, I will need you to please give me an example of a string or multiple examples and I will also need access to the site.

I will enable the private fields below in case that will be needed, but usually that would be the process that needs to be followed and you might find them there.

Please let me know how that goes.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

May 8, 2019 at 4:06 pm #3768877

Marzia

Hello Mihai, Thank you, fantastic! its seems to work, and I 've found many strings, not all of them but i need more time to check properly, so I need to leave this ticket open for a while.
In the meantime I ask you another thing: how i can disable wpml editor for posts and pages? I just want to use wordpress classic editor because I use WpBakery visual composer. I see wpml editor when i click on the pen icon in the page list of first language, but not when I use the flag on the top admin bar, switching full content in the second language. In that way, when I click on page titles edit screens show in the correct way. Hope having described properly 🙂 Thank you!

May 8, 2019 at 4:12 pm #3768963

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I am very happy to hear that the advice above helped.

Regarding your new question, you should be able to use the functionality that is presented in the documentation here:
https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/

Hope that helps, too! 🙂

Kind regards,
Mihai

May 8, 2019 at 4:23 pm #3768983

Marzia

I don't have the option described in your link.
Anyway there isn't anything to set globally instead of operating in each post/page?
Thank you!

May 8, 2019 at 4:32 pm #3769081

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

From what I can see, you have Italian set as the default language so I think you should be on the default language edit page to find that option.

In the screenshot you attached, it seems that you are on the English-translation page.

Regarding your question ("isn't anything to set globally instead of operating in each post/page?"):

- as it shows in the screenshot here (hidden link), after you click that option, you should be able to decide how do you want it to be applied - only to that page, to all the pages or to all the site's content.

If for whatever reason that option still won't show up for you, I will need you to please open a new ticket with that issue.

Due to our policy, we try to keep one issue per ticket.

Continuing with one issue per ticket helps not only supporters to focus on one issue at once, but also enables other users to find solutions to their questions faster.

I hope however that the information above will help. 🙂

Kind regards,
Mihai

May 8, 2019 at 4:57 pm #3769355

Marzia

Fantastic! you were right! found and definitely changed!! thank you so much! :)))
- For the main issue, i found all strings, added to String Translator and translated them, but "choiches" of those checkboxes don't show up translated in the English frontend.
Example those related to "Services" (see two attachments)
- Second thing: I have the string "Area geografica" shown twice with wrong language in String Translator list, and in the english frontend shows wrong too. (show third attachment)
Thanks for help!

May 9, 2019 at 9:18 am #3774523

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I am happy to hear that we are making progress! 🙂

For the first issue, I will like to take a look on the site.

For the second issue you reported, that happens from time to time and you should not care too much about it, just try to translate all of them and see if the translation works. From what I can see, 2 of them are set as English (default lang) and one of them is set as (Italian). Just translate all of them accordingly and see if that works.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai

May 9, 2019 at 4:42 pm #3778119

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Can you please let me know how did you get to the screenshot I attached?

Is there a link you can share with me?

May 9, 2019 at 4:46 pm #3778153

Marzia

It's true, I'm really sorry, I forgot to give you the page link!
here we go:
hidden link

italian site (first language):
hidden link

you can check and edit my profile as you like (Marzi Agnetti), is there for testing.
Thank you!

May 10, 2019 at 9:06 am #3782477

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Please follow the next 2 steps and let's see if anything changes (from what I see, the strings are translated correctly inside WPML > String Translation):

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased as the minimum requirement for WPML is 128Mb WP Memory Limit: https://wpml.org/home/minimum-requirements/

❌ Very important: please make a backup of your site (files & database) before following any of the upcoming steps ❌

Please add this to your wp-config.php file to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy blogging. */

These settings can be limited directly by your hosting provider, so, if that’s the case, I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

2. We need to increase the MaxInputVars to 42000 - currently, you have them set at 3000.

For this, please try to set this variables in your php.ini:

max_input_vars = 42000;
suhosin.post.max_vars = 42000;
suhosin.request.max_vars = 42000;

You may need to contact your hosting provider to set them.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

Let's see if these 2 things solve the issue.

I will be waiting for your response.

Kind regards,
Mihai

May 10, 2019 at 10:27 am #3783277

Marzia

Thank you Mihai, I made all this but nothing has changed.
thanks

May 10, 2019 at 4:27 pm #3786677

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Thank you for the confirmation.

I was trying to look after this plugin in our official WPML-compatible plugin repository here (https://wpml.org/documentation/plugins-compatibility/) but I was not able to find it which means that we might be dealing with a compatibility issue.

I created this clean WordPress setup where we will use just WordPress, the WPML plugins and the UPME plugin (+any other plugin that the UPME plugin depends on if that's the case - I think it might not be the case) to try to replicate the issue.

So what I would need you to do is go here (hidden link - one click login authentication so just click the link), set up WPML as you have it on your site, install and set up the UPME plugin and see if you can replicate the issue on a clean install.

If the issue will happen on our servers, too, then I can forward this to your Compatibility department.

Please let me know how it goes. I will be waiting for your answer.

Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week in case you respond tonight or this weekend.

Kind regards,
Mihai

May 10, 2019 at 5:39 pm #3787107

Marzia

Thank you Mihai, you are great!
I will try to test on your link on Monday too, so have a nice weekend! 🙂

May 13, 2019 at 12:25 pm #3798055

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Thank you for your kind wishes, the weekend was great.

Happy Monday to you! 🙂

I will assign the ticket to you so please get back to me after you are able to follow the steps in my last reply and let's see what we will be able to find out.

I will be waiting for your reply.

Kind regards,
Mihai