Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Andreas W. 4 months, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
September 3, 2020 at 2:10 pm #6935735

antoninR-2

Hi, on this page, I would like to translate the URL of buttons "Discover"(hidden link). As It's going on French page while I am on english page. I don't find the URLs in translation editor while in other translation pages it's showing the URL(hidden link). How can I do?

September 4, 2020 at 7:22 pm #6945957

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Those buttons lead towards the product categories.

Please go to WPML -> Taxonomy Translation and choose the product categories from the dropdown.

Now, first at the bottom of the page make sure that the category base is assigned to the correct language and translated, especially the slug is important here. Choose a unique slug for each language.

Then make sure that also the cateogries are translated.

You could also take this edits at WooCommcer -> WooCommerce Multilingual -> Product Categories. Also please verify the Status tab and le tme know if you see any errors or notifications.

Further, here at the right bottom corner you will see the option "Troubleshooting". Try running the sync options of the issue is still not solved. If this will not solve the issue please reach out again.

Kind regards
Andreas

September 8, 2020 at 7:59 pm #6969975

antoninR-2

Hi,

I did exactly this process but the page is still going on the french page and don't see the URL to translate in traduction. (hidden link)

September 8, 2020 at 8:11 pm #6970001

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

September 8, 2020 at 8:35 pm #6970097

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have adjusted and synchronised the taxonomy translation for product categories.

Could you please revise again and let me know if you spot another issue?

Kind regards
Andreas

September 8, 2020 at 8:38 pm #6970099

antoninR-2

Still a problem - it's showing 404 error : hidden link - click on Discover you will see

September 8, 2020 at 11:52 pm #6970471

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

The catelgory pages are working as expected.

The problem on the mentioed site was that when you created those buttons the category base was not translated. Now, the englisch buttons include the wrong category base which is in this case /categorie-produit/.

At this point I updated the original page inside Elementor and applied the translation again which solved the issue for the buttons.

Let us know if you run into further issues.

Kind regards
Andreas

September 9, 2020 at 7:30 am #6972329

antoninR-2

My issue is resolved now. Thank you!

September 9, 2020 at 1:40 pm #6976581

antoninR-2

Hi andreas,

After checking, I still have problem of URL translation when I click on the images of this page for instance : hidden link

September 9, 2020 at 5:56 pm #6978637

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

As this ticket was already marked as resovled the account credentials been removed automatically.

Could you please provide admin access again?

Kind regards
Andreas

September 10, 2020 at 6:11 pm #6987777

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

As far I can see this is not a WPML issue, as those are Elementor Image Widgets which have no link declared. See screenshot.

I have now changed the image link to a personalized URL and added the URL that is used on the button.
Then I saved the page and translated it again. The image link appears inside the WPML Translation Editor and can get translated now.

Kind regards
Andreas

September 11, 2020 at 3:22 pm #6995397

antoninR-2

Awesome ! Still need help for this page : hidden link - I also added URL but this time in Elementor Column - it's going on the french version when I click on. How can we translate that?

September 11, 2020 at 5:59 pm #6996383

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Go to hidden link

Inside the top admin bar click "Edit with Elementor".

Edit the URL, accordingly.

Example:

French: hidden link
English: hidden link

I hope this clarifies your question and solves the issue.

Kind regards
Andreas