This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Harshad 5 years, 1 month ago.

Assigned support staff: Harshad.

Author Posts
August 10, 2014 at 1:43 pm #450162

krzysztofM

Hi,
I;m trying to translate my site, but it's quite hard.
I'm able to translate some widgets to english and then again to polish - but some of them are not even displaying on english.

Mostly I got problems with widgets like "My Advanced Cycle".
See: home page (no widget below "From project to effect" text.)
hidden link
hidden link

See:about us (problem with our team and reccomendations - no photos)
hidden link
hidden link

August 10, 2014 at 1:59 pm #450163

krzysztofM

And Media is not shoing on translated part. Even If I have WPML Media active.
How to setup auto copy featured image? I do not get it.
See:
hidden link
hidden link

August 11, 2014 at 6:53 am #450301

Harshad

Dear Krzysztof,

This is how widgets are normally translated:

1. If you are using the WordPress default widgets you will be able to translate both the title and content under the "WPML -> String Translation" screen

2. If you are using custom widgets which are coded correctly and use apply_filters on widget_title and widget_text then again you should be able to translate both the title and content under the "WPML ->
String Translation" screen.

Note: If you are coding your own widgets see: Texts in widgets needs to go through 'apply_filters': http://wpml.org/documentation/support/troubleshooting-string-localization/

3. Sometimes the above options are not enough. In this case you may want to look into using Widget Logic see:http://wpml.org/2011/03/howto-display-different-widgets-per-language/

August 16, 2014 at 9:58 pm #453164

krzysztofM

Ok. I'll take a look into my widget titles.
But how about photos? As I said and you can see, when they are in code or feature image they are fine. But when they come from widget they are lost.

Also to do not make new topic, I got problemy with my front page.
When I try it on my second pc and in private mode I got 404 error. Even if I did my polish and english translations.

Wierd thing is when I login to my admin page, I see front page working well.

This is to be fixed asap. Most important.

Sorry for delayed reply, but I wasn't notified by email.

Hope you'll know how to help me.

August 16, 2014 at 9:59 pm #453165

krzysztofM

Add to my issue:
Polish (default one) is not working, ENglish is working fine (if you do now count few images lost).

August 18, 2014 at 5:19 am #453302

Harshad

Can you please try this:
Go to WordPress admin -> WPML -> Support, Click on the troubleshooting link at the bottom of the page.

On troubleshooting page
1) Click "Remove ghost entries form translations table" button.
2) Click "General cleanup" button.
3) Click "Set language information" button.

Let me know clicking above buttons, help to resolve the issue.

The topic ‘[Closed] Translate widgets’ is closed to new replies.