Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Alejandro 1 year ago.

Assigned support staff: Alejandro.

Author Posts
October 16, 2018 at 7:39 am #2819956

Angela Tatli

Hello support team of WPML,

my website is bilingual. German is the main language and English the translation. I use the divi editor for each language.

How is it possible that WPML makes a translation in the editor on the English side with the Divi editor?
Which settings should I choose?
I'm grateful for support.

Many greetings
Angela

Tell us what you are trying to do?

Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site?

October 17, 2018 at 8:07 am #2823645

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,
Welcome to WPML Support.
I'll do my best to thelp you solve this issue.

I understand from your request that you want to use DIVI Builder for the english translation instead of using the Advanced Translator Editor from WPML.

If that's the case, then you just need to go to WPML > Settings > How to translate posts and pages > Select "Create translations manually".

As soon as you do that the translator will be deactivated and you'll be able to translate using DIVI Builder.

Just a tip: As soon as you go to the page you want to translate, and click on the Translate icon (the blue Plus sign on the "Language" section of the page/post.- See Attachment : "Language Tap Translation.jpg") you'll create a new blank page in the other Language (English).

If you want to keep the same structure of the divi builder as the original, click the " Copy content from [Language]" button (it should say "Copy content from English" in this specific scenario - See attachment "copy content from language.jpg")
this will overwrite everything you had previously written in the translated page/post and set the same content as in the Default language (German) and might save you some time.

If instead you want to translate your site using the Translator editor, i suggest you follow this tutorial: https://wpml.org/documentation/theme-compatibility/divi-builder/

It's a very detailed tutorial that will surely help you get started with WPML and DIVI Translations.

Let me know how it goes, and if you need any more help, you can always let me know. I'll gladly try to solve your problem.

October 21, 2018 at 4:09 pm #2835682

Angela Tatli

Hello Alejandro,

thanks for your support.
The main language on my website is German
I have a Puigin installed duplicates the post. I start editing the duplicated German post and rewrite it. Then I go to the duplicated English post and wrote it in English myself. In the column on the right side, the translation button is not activated. I sent you a screenshot of what that looks like. Maybe I don´t have the right settings.
The button with "Copy content of language" is also missing.
This message always appears in the English Post "Warning: You are trying to edit a translation that is currently being added with WPML."
What is wrong?
I already have under "Translation Editor Options"
"Create translations manually" selected.
If this is not the right way to organize my translations and there is an easier way then I am grateful for information.

Gany greetings
Angela

October 22, 2018 at 8:38 am #2837300

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello!

You're actually doing great, you just might have been misguided by my previous answer. You had already followed the steps i mentioned above, so the layout slightly changed.

- "The button with "Copy content from [language]" is also missing."
The button is there, it's written like this in German: "Inhalte von Deutsch kopieren" (Screenshot: "Copy from language.jpg"). It's not clickable because you had already clicked it in the past (Probably not directly, but through the translation editor).

- "In the column on the right side, the translation button is not activated"
You're right, it's not there, but only because you have already translated the content. in that case, that language moves to another section called "Translations" which i can see in the screenshot you sent me (Screenshot: "translations section").

-"This message always appears in the English Post -Warning: You are trying to edit a translation that is currently being added with WPML.- "
This is happening because you have added that page in WPML > Translation Management. Try going there and clicking the "Translation Jobs" Tab, you'll probably find that page in there. That warning is not dangerous, it's just informative so you don't have to worry about it.

As i mentioned earlier, you're doing great (congratulations!) and it seems you have correctly translated the page, already.

You could check this documentation about translating content from Visual builders manually. I believe it will make everything clearer for you: https://wpml.org/documentation/translating-your-contents/page-builders/translating-content-created-with-page-builders-using-manual-translation/

If you keep having issues you can just ask me and i'll gladly keep helping you. If you feel this is resolved or have other WPML issues, then i suggest you close this ticket and open a new one. You can even assign the new ticket to me and i'll do my best to solve that new issue!

October 22, 2018 at 10:11 am #2837581

Angela Tatli

Hello Alejandro,

I have read all the instructions. Unfortunately that does not look like it for me.
Sorry!
What have I done!
I duplicated my last post. So the last post is now duplicated in German and English. Now I am writing and designing the German post. This is what the WPML box looks like on the right side see screenshot (1) now I click on see my red mark with arrow.

Now I come to the English page where is still the duplicated old English post.
In the WPML box on the English side I click (2) (See screenshot with my red mark) and everything is copied only in German as I just wrote it.
I can´t find this box see screenshot (3).

What am I doing wrong?

Many greetings
Angela

October 22, 2018 at 2:47 pm #2838495

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

I see what your problem here is.

The plugin you used to duplicate the page is fully compatible with WPML, maybe even too compatible. It automatically duplicated your page and its translation, that's why it seems like it's already "translated" right from the first time you access the page.

To fix that, do the following:

Go to the translated page (English) and erase everything on it. You can do so by clicking the "Text" tab in the WordPress editor (Screenshot: "Text editor Tab.jpg") and then by erasing everything in it.

Then you can copy the content from German and translate normally into English, using the button i suggested in the earlier replies (Screenshot: "copy from language.jpg").

I hope this fixes your problem, don't hesitate to let me know.

October 22, 2018 at 3:45 pm #2838743

Angela Tatli

Hi Alejandro,

I duplicated the posts and deleted the English post. As you have described to me. Then I wrote the German Post and wanted to translate the English but the problem is the same.
I use the Pluig in "Duplicate Post by Enrico Battocchi" should I take another?
If so, which.

many Greetings
Angela

October 22, 2018 at 3:59 pm #2838851

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

That's weird, i tested it on my end and it worked.

You can also try this plugin: https://wordpress.org/plugins/page-or-post-clone/

This above mentioned plugin will only translate the current page and will not translate its translations. I suggest you try duplicating the page you want to translate to English again and follow the suggestions on my first reply and see if this works better for you.

Check it out and let me know.