Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Bruno Kos 4 months, 1 week ago.

Assigned support staff: Bruno Kos.

Author Posts
July 12, 2019 at 5:59 am

Henry Chandra

I am trying to: do 100% translations. It didn't work. BUT if i make it less than 100% it DOES save but DID NOT publish and nowhere can be found on the posts list for that translated language.

Link to a page where the issue can be seen: hidden link

I expected to see: it saved and published with that 100% translated fields.

Instead, I got: a loading icon that takes up too much time upon clicking "Save & Close" but did not perform anything. It does save but it did not publish. When i refreshed or go to this post again, it does displaying me the 100% translated.

I even tried to run START button on this settings:
WPML > Settings > Media Translation

Unfortunately did not work either. Other than that i have also define my WP_MEMORY_LIMIT to 512M but this wordpress keep showing 40M. My other server was also showing the same.

July 12, 2019 at 10:04 am #4197371

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Thank you for contacting WPML support!

I believe that the reason is this error - have a look at what I am getting in the Chrome console log when trying to save. This is most likely stopping the save from happening. I'm not entirely sure what is behind this, because these points to WordPress core files. I was able to find something similar here, but I cannot guarantee that it is the culprit:
https://wordpress.org/support/topic/errors-in-v2-9/

Therefore, I suggest you do the following:
- update WordPress and all the plugins on the site
- if the issue persists, leave only WPML active and try then
- if it works then, then it is a compatibility issue with some other plugin, so try activating one plugin at a time to see which one will cause the issue

Hopefully updating plugins and WordPress alone will do. As for the PHP setting, you should probably consult your hosting about this because WPML only reads this value and does not set it, but let me give you an example on how it is on my localhost and how it should be done (wp-config.php):
hidden link

 define( 'WP_MEMORY_LIMIT', '512M' );

/* That's all, stop editing! Happy publishing. */

/** Absolute path to the WordPress directory. */
if ( ! defined( 'ABSPATH' ) ) {
	define( 'ABSPATH', dirname( __FILE__ ) . '/' );
}

/** Sets up WordPress vars and included files. */
require_once( ABSPATH . 'wp-settings.php' );

Regards,
Bruno Kos