Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 22 replies, has 2 voices.

Last updated by Henry Chandra 5 months ago.

Assigned support staff: Yvette.

Author Posts
July 1, 2019 at 8:30 am #4116601

Henry Chandra

I am trying to: translate to 100% that have many fields

Link to a page where the issue can be seen: hidden link

I expected to see: it saved and published with that 100% translated fields.

Instead, I got: a loading icon that takes up too much time upon clicking "Save & Close" but did not perform anything. It does save but it did not publish. When i refreshed or go to this post again, it does displaying me the 100% translated.

July 1, 2019 at 8:53 am #4116709

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

1. Min system requirements
I notice that you still have only 40M of PHP memory allocated to WordPress. This is the default amount that is allocated when you install Wordpredss.

The minimum for normal WPML functioning is 128M but we recommend that you allocate as much as you can.
More here:

Please add the following line to your wp-config.php file

https://wpml.org/home/minimum-requirements/

Often, the inability to complete the publish action is related to not having enough PHP memory to complete the action.

2. WordPress Debug mode
After having corrected the memory allocation, if you still have problems publishing, please enable the WordPress debug mode by adding/changing the following line in the wp-config.php file:

define('WP_DEBUG', true);

Then, try to save the translation again and write back with any system messages that appear on your dashboard or log.

3. Compatibility problems
Finally, if you STILL cannot publish, please do the following steps
- temporarily change your active theme to Twenty Nineteen
- temporariliy deactivate you non-WPML plugins
- again, attempt to complete the Translation Editor save.

Are you able to do it?

Thanks

Thanks

July 4, 2019 at 6:31 am #4140433

Henry Chandra

Hi Yvette,

Apparently our PHP memory is already increased to 512M .However, in the WP-Memory-Limit it's still showing 40M. (see the attached picture for you reference) . I strongly feel that it must be something to do with the wordpress plugins.

I even configure the WP-Memory-Limit in the wp_config file with this code:
define( 'WP_MEMORY_LIMIT', '512M' );

Unfortunately in the wordpress it is still showing 40M . Kindly assist

July 4, 2019 at 6:35 am #4140467

Henry Chandra

I'm sorry i sent you the wrong image. This is the correct one.

P/s: We tested out on 3 different server and these servers got the same php info of memory limit 40M in wordpress eventhough our memory limit is already increased.

July 4, 2019 at 7:32 am #4140785

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

That´s strange.

1. Temporary Access to your system
Please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem. The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

July 8, 2019 at 6:18 am #4159281

Henry Chandra

I am waiting your reply please assist.

July 8, 2019 at 9:26 am #4160529

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

It seems that you did not complete the steps for translating the media in:
WPML > Settings > Media Translation

I only executed the 1st two required steps and now the translations are completing and closing.
Can you check this on your end?

July 8, 2019 at 9:44 am #4160561

Henry Chandra

My issue is resolved now. Thank you!

July 8, 2019 at 9:58 am #4160739

Henry Chandra

Hi Sorry but i did try like u mentioned but didn't resolve. Can you provide the screenshot of which part you changed in media translations?

July 8, 2019 at 10:05 am #4160807

Henry Chandra

I would like it to be more descriptive

July 8, 2019 at 10:49 am #4161375

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

The steps I executed should not have to be executed again. But for your infomation, see the screenshot.

In theory, you should execute the last two steps as well but since there are so many images, I did not do this.

Are you still having an issue - if so, please send the page link and details

July 9, 2019 at 2:14 am #4166647

Henry Chandra

Ahh no wonder. I miss the Settings parts and went to different media translations.

However, i did like how you showed me in the picture. Its still not working. I only tick the "Translate existing media to all language" and click on the "Start" button.

Then i went back to the translated page and go ahead to translate it to 100% but its still loading for so long . (This is on another server)

July 9, 2019 at 2:18 am #4166683

Henry Chandra

Is this all only related to configurations? It doesnt needed ftp so far am i right?

July 9, 2019 at 7:07 am #4167919

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

This is a configuration step that only should happen ONCE.
If you have not executed this installation step in your other server, you should comlete all 4 options and select START.

Right now, I am a bit confused as to what problem we are trying to resolve and on which server. If the problem is on another server, there coudl be other reasons for the issue (memory, compatibility,...etc) and you should open a different ticket or provide access details for that server.

July 9, 2019 at 7:55 am #4168265

Henry Chandra

Hi Yvette,

The server that we provide you is a copy of the other server. I have executed those 4 options and clicked START however it did not work.