Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Yvette 5 months, 2 weeks ago.

Assigned support staff: Yvette.

Author Posts
June 6, 2019 at 8:57 am #3967227

rufusB

This thread was not resolved https://wpml.org/forums/topic/second-language-my-account-lost/page/2/

What happens is that the account endpoints disappear when you make any edits to anything, anywhere with elementor while string translator is active.

June 6, 2019 at 2:17 pm #3969877

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

1. Clarification
1.1 I understand the issue to be as follows:
When Elementor and String translation are active, if you make an edit to a post, the woocommerce account endpoints "disappear".

Is this a correct restatement of the problem?

1.2 Were you able to reproduce this problem on a sandbox site? It was not clear from the messages of your last thread.

2. System Access
Please provide wp-admin and ftp access to your site. I am opening the private area for this information. The information is only visible between you and WPML Support.

3. Example
Please communicate clear and detailed steps on how I can reproduce this issue on your site.

4. Diagnostic
Does this behaviour exist if you temporarily change your theme to Storefront and if you also temporarily deactivate you non-WPML plugins (except for Woocommerce and Elementor)?

Thanks for the extra info.

June 7, 2019 at 6:52 am #3974273

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

I was unable to reproduce the problem. Here are the steps I did:
0. Activate String Translations
1. Edit the post "Issues" with Elementor by adding a space, removing it, and then select "Update"
2. Open a new tab on the website.
3. Switch to Castellano
4. Select "Mi Cuenta"
5. Select any of the tabs - they all opened ok for me.

I did have to make the following changes to your URL configuration in order to access the ES site without having to login fresh each time:

- WPML > Languages > Language URL Format > "Auto sign-in and sign-out useres for all domains" (enable)
- WPML > Languages > Language URL Format > Pass arguments via POST (enable)

Am I executing the required steps correctly?

June 7, 2019 at 8:34 am #3974779

rufusB

Yes, you did everything right and I did the same today. We got the same result. That leaves me scratching my head. It's not the first time I thought I'd isolated the cause only to find I hadn't and it looks like the only constant is that editing something in elementor with string translator deactivated brings the tabs back. The only new thing I can think is that I recently re-scanned Link Targets from Multilingual content Setup. Is that likely to have any bearing on this?

June 7, 2019 at 8:51 am #3974921

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

I think it has more to do with the changes I set in the languages URL configuration.

When I first tried the steps you mentioned, I was continuously being asked to re-login to the site in ES.

As a test, you can try reversing the steps I did and see if the problem comes back. Sepcifically, this would mean:
- disabling the "Auto sign-in..."
- changing the way to pass URL arguments to use "GET" instead of "POST"

June 9, 2019 at 11:01 am #3982717

rufusB

I had to undo your changes as I was unable to save any edits in elementor, the "Auto sign in" doesn't work, and, worst, but most interesting in a tedious sort of way, is a new twist to an old problem which has been on your second tier support "do nothing about" list for 6 or more months now.

Every translated caption on every elementor image of every page, was broken. Previously, this would only occur on the page being edited in elementor while string translator was active. I'm not going to test which of the changes is responsible, I don't have another two hours to reinstate the captions. https://wpml.org/forums/topic/image-captions-on-one-elementor-page-have-mostly-disappeared/

June 9, 2019 at 5:46 pm #3983545

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hmmm

I see there are several tickets opened regarding this problem and I´m sorry that I was not aware of this before.

So it seems that you cannot resolve the "preview" without affecting custom caption translation?

I also confirm that this issue has been raised to the development team but I have no update to share with you about it.

The topic ‘[Closed] Translated account endpoints disappear with elementor & string translator’ is closed to new replies.