This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by victorN-3 4 months, 2 weeks ago.

Assigned support staff: Noman.

Author Posts
May 27, 2019 at 9:35 am #3895425

victorN-3

I am trying to:

Show the Dutch translation of cookie notice in the Dutch translation.

Link to a page where the issue can be seen: hidden link

I expected to see: Dutch translation

Instead, I got: English version.

May 27, 2019 at 9:46 am #3895479

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. We have another client who had the similar issue and was also able to solve it, this may help in your case (Summary at top):
https://wpml.org/forums/topic/cookie-notice-plugin/#post-2064848

Please let me know if this resolves your issue or you need further assistance.

Thank you

May 27, 2019 at 9:57 am #3895537

victorN-3

Hi Noman,

thanks for the reply.

It does not apply to me, the options in that article (already visited and read before contacting you) are not valid.

I don't have the option of custom xml translation in translation management.

Cheers,
Victor

May 27, 2019 at 10:29 am #3895939

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Sorry for inconvenience. Now you can find Custom XML Configuration section from WPML >> Settings menu as you can see in the attached screenshot.

If still issue persists, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

May 27, 2019 at 11:55 am #3896897

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have logged in to your site and searched ‘we use cookie’ string in WPML >> String Translation and found 2 results. I just entered the test translation in correct domain, cookie strings starts showing correct translation as you can see in attached screenshot.

You can add correct translation from WPML >> String Translation section.

Thank you

May 27, 2019 at 12:27 pm #3897161

victorN-3

Great thank you, it works. just the button privacy policy is not translated.
I searched for privacy policy but I did not find anything. all cookie notice fields are now translated according to string translations.

May 27, 2019 at 3:58 pm #3899491

victorN-3

Anyone there?

May 28, 2019 at 5:12 am #3902733

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have followed same steps for ‘Privacy policy’ button text, logged in to your site and searched ‘Privacy policy’ string in WPML >> String Translation and found 3 results. I just entered the translation in correct domain, cookie button starts showing correct translation as you can see in attached screenshot.

Please let me know if this resolves your issue or you need further assistance.

Thank you

May 28, 2019 at 1:13 pm #3907263

victorN-3

My issue is resolved now. Thank you!