This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 2 voices.

Last updated by jonas-ochF 5 months, 2 weeks ago.

Assigned support staff: Jamal.

Author Posts
April 24, 2019 at 7:15 pm #3676219

jonas-ochF

I am trying to:
Access my translated blog posts from the blog overview

Link to a page where the issue can be seen:
English blog overview: hidden link
English blog post (original): hidden link

Swedish blog overview: hidden link
Swedish blog post: hidden link

I expected to see:
The translated blog post.

Instead, I got:
"Inga resultat hittades" ("No results found")

April 25, 2019 at 9:43 am #3680683

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for contacting WPML Support. I will be glad to help with this.

Please make sure blog posts translations are marked as complete and save permalinks in Settings->Permalinks.
I can access this page which seems to be the translation for the blog overview
hidden link

Note that posts are showing in english, so my guess is that translation is not marked as complete.

If this does not help, please make a database backup and execute all cleanup actions in WPML->Support->Troubleshooting.

If it does not help, please allow me temporary access to your backend to investigate this further.

Best regards,
Jamal
WPML Support

April 25, 2019 at 12:50 pm #3682575

jonas-ochF

Thanks for your reply. It looks to me like the post in question is translated - unless I'm looking in the wrong place? Here's a screenshot of it from my posts overview.

April 25, 2019 at 1:44 pm #3682995

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi,

I think that it is translated too, maybe not complete, but according to your screenshot, it is completely translated.

Have you been able to save permanlinks ?
Have you run the cleanup actions in WPML Troubleshooting ?
Can you activate debugging and try to access a translated post.
1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/ .
2. Repeat the action of creating the problem(Visit a translated post).
3. Share the debug.log (log file inside the /wp-content/ directory) here or using DropBox or GoogleDrive.

Finally would you allow me temporary access to your website so i can investigate this closely.

Best regards,
Jamal

April 25, 2019 at 2:12 pm #3683201

jonas-ochF

I don't know where to find my wp-config.php though?
I'm running a hosted business WordPress account, where can I find the wp-config.php?

April 25, 2019 at 2:20 pm #3683335

jonas-ochF

I might have found something weird here: I switched the permalink setting to be just post=postid instead of the custom ones, and it seems like the Swedish version of the blog overview sends me to a different post id than the English version. See screenshots attached.

English blog (hidden link) sends me to: hidden link
Swedish blog (hidden link) sends me to: hidden link

I notice that the Swedish and English blog overviews have different page_ids so maybe that's expected though?

April 25, 2019 at 2:20 pm #3683381

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

wp-config.php is in the root folder of the wordpress install, but as you are on a hosted install, i suggest you ask wordpress supporters to activate PHP debugging.

Best regards,
Jamal

April 25, 2019 at 2:40 pm #3683591

jonas-ochF

Will do.

April 25, 2019 at 2:58 pm #3683667

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Thank you, please share with me the content of debug.log file, maybe it will reveal something that could help us resolve this issue.
Looking forward to you reply.

Best regards,
Jamal

April 25, 2019 at 5:47 pm #3684817

jonas-ochF

Update from the WordPress team is that you guys need to enable the debug mode. See attached conversation with them.

April 25, 2019 at 5:52 pm #3684845

jonas-ochF

Further updates. WordPress claims (rightfully, I'd say, since it's your plugin and they have given plugin owners the right to enable debug mode) that it is your responsibility to enable the debug mode. Can you do that for me asap? We're having to hold back on posts at the moment due to this issue.

April 25, 2019 at 5:58 pm #3684885

jonas-ochF

Update again: The WordPress folks kindly had a look at any server log errors they could see on their side. They found this which they asked me to send through to you:

[24-Apr-2019 18:57:27 UTC] PHP Fatal error: Uncaught Error: Class 'WPML_TP_Sync_Orphan_Jobs_Factory' not found in /srv/htdocs/wp-content/plugins/wpml-translation-management/classes/upgrade/class-wpml-tm-upgrade-loader.php:61
Stack trace:
#0 /wordpress/core/5.1.1/wp-includes/class-wp-hook.php(286): WPML_TM_Upgrade_Loader->wpml_tm_upgrade('')
#1 /wordpress/core/5.1.1/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)
#2 /wordpress/core/5.1.1/wp-includes/plugin.php(465): WP_Hook->do_action(Array)
#3 /wordpress/core/5.1.1/wp-settings.php(505): do_action('init')
#4 /srv/htdocs/wp-config.php(84): require_once('/wordpress/core...')
#5 /wordpress/core/5.1.1/wp-load.php(42): require_once('/srv/htdocs/wp-...')
#6 /wordpress/core/5.1.1/wp-admin/admin.php(34): require_once('/wordpress/core...')
#7 /wordpress/core/5.1.1/wp-admin/update-core.php(10): require_once('/wordpress/core...')
#8 {main}
thrown in /srv/htdocs/wp-content/plugins/wpml-translation-management/classes/upgrade/class-wpml-tm-upgrade-loader.php on line 61

April 26, 2019 at 7:36 am #3688483

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi :-),

They finally activate PHP debugging and shared only a part of it.
I can agree with the support that developers have(shoud have) ways to 'debug' their software, but when we talk about PHP debugging, it is up to the platfrom/hosting provider to activate or deactivate it.

Any way, this error happened in 24-Apr-2019 18:57:27 UTC. And can be caused by an incomplete update of the plugin Translation Management, i can only guess. I'll need to see the debug log for the specific times i am testing on.

Would you like to ask wordpress.com support to provide us with a Jetpack backup, so i can build your website locally and investigate this issue ?
We usually use Duplicator for this, but my colleagues told me that wordpress.com can offer a JetPack backup. I activated the private box for duplicator to share a download link securely.

Or you may want to migrate your website to one of our servers, so we can debug this issue in a server which we have full control over it. Then we can implement the fix in your live site.

Looking forward to you reply.

Best regards,
Jamal

April 27, 2019 at 5:45 pm #3696019

jonas-ochF

Hi Jamal!

I finally managed to resolve the issue. For your information if others run into the same issue, I realized that while it looked like the post was translated and published from the posts view, that was only the English version. I clicked "Swedish" in the link menu, and then noticed that the Swedish post for some reason was still in Draft mode (see screenshots).

Before we close this issue, I want to know if you have any idea as to why that happened? I thought that all translated posts automatically got the same status as their "parent" posts, but I guess that is not true?

Kind regards,
Jonas

April 27, 2019 at 8:59 pm #3696217

jonas-ochF

Update: It seems I was too quick on the trigger before - something is still seriously broken. Now, I don't get a 404 page not found error anymore, but instead just a blank page without any of the translated post. See screenshots.