This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by Itamar 6 months, 2 weeks ago.

Assigned support staff: Itamar.

Author Posts
September 18, 2019 at 3:21 pm

martijnv-36

I am trying to: Translate a page with ACF fields with the ATE. I'm able to create the translation but when I deliver it the translated ACF fields are empty

Link to a page where the issue can be seen: hidden link

I expected to see: A translated page

Instead, I got: Empty ACF fields.

September 19, 2019 at 11:57 am #4604405

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I've checked things on your site. I could see that the /menu/ page is not set to be edited with WPML's classic Translation Editor. And I could see that it is not 100% complete. When I made the translation, 100% complete things work. Now the English page is showing the translations. Please see the attached screenshots.

If you need to use WPML's ATE and it still not working for you, please let me know. But before please correct the following.

By looking at the debug info that you have attached I can see that your server WP Memory Limit is set to 40M.
Our recommendations are to have the following as minimal requirements:
- PHP 5.6 and above (this OK with your installation) with a WP Memory Limit of at least 128MB and more if possible.
- MySQL 5.6 and above (this OK with your installation).
Please follow this link for detailed documentation:
https://wpml.org/home/minimum-requirements/
Is it possible for you to change those to the minimum requirement?
You may need to contact your hosting provider for that.
Meeting those baseline requirements is most critical before starting to debug and sometimes solves issues like you experiencing.
Most important is to raise the WP Memory Limit.
Please try to raise it before you contact your hosting company.
You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code in that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it before this line:
/* That's all, stop editing! Happy blogging. */

Could you please perform that procedure and see if it help?

Also please make sure that it is not a cache issue. When making changes on your site clear the cache from your site to make sure that the changes are applied.

Thanks,
Itamar.

September 22, 2019 at 9:28 am #4617975

martijnv-36

I added the lines of code to the website but the problem still persists... I've added a link to a video showing what I do and what goes wrong. -> hidden link

September 22, 2019 at 4:42 pm #4619055

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thank you for the video.

When I follow the steps that you show on the video, I can see this issue on your site.

I can also see that the Advanced Custom Fields PRO plugin is not updated to its latest version on your site. You currently have version 5.7.8, and the latest is 5.8.4
Could you please update ACF Pro to the latest version and see if it helps to solve the issue?

Thanks,
Itamar.

September 25, 2019 at 12:03 pm #4638519

martijnv-36

I have successfully updated ACF Pro to the latest version but the same problem still persists.

September 26, 2019 at 12:26 pm #4646779

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for trying my suggestions.

You are using repeater fields. Please make sure that you are setting their translation preference as described in our documentation here.
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#setting-the-translation-preference-for-repeater-fields

But also when I investigated this issue, I've noticed that the subfield (menu_fields) of the main repeater field (food_menu), is set as a clone field. Please see the attached screenshot. And it is cloning the fields from Fields Menu group. I'm not sure that WPML can work with this.
Can you please try and see if things work when you create the repeater field with actual subfields on the same group and not cloned fields?

Thanks,
Itamar.

October 22, 2019 at 4:45 pm #4804421

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Have you tried to set the subfield (menu_fields) to be a repeater field and not a clone field as I suggested here?
https://wpml.org/forums/topic/translated-content-made-with-ate-not-showing-up-on-frontend/#post-4646779

Regards,
Itamar.

November 3, 2019 at 12:27 pm #4876427

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I've checked things on your site and found the following.

A. The minimum requirement of WP_Memory_Limit was not set correctly. It was set to 40M. Please see the attached screenshot wp-memory-limit-40.jpg.
So I've increased it by logging into your site with FTP and adding the following lines to the wp-config.php file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

B. According to our documentation about how to work with PWML and the ACF plugin regarding repeater fields, I could see that the settings of some of the repeater fields and subfields were wrong. Please see the attached screenshot repeater-setting.jpg
So I corrected it. You can see our documentation here.
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#setting-repeater-and-flexible-fields-translation-preferences

Unfortunately, the above didn't help to solve the problem. The content of the menu page in English still does not show. Therefore, I've installed a copy of your site (from the duplicator package that you sent me) on my local server, and I'll continue to debug this issue. I'll check things and keep you updated here.

Thank you for your patience.
Itamar.

November 4, 2019 at 5:14 pm #4883533

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

For quite some time, I was working on the copy of your site that you have sent us on my local server and debugged this issue. I've had progress in resolving it, but then I realized that the custom fields groups on the copy that you have sent me are not the same as they are now on your site. Settings have been changed. I'm going to need to create a copy of your site from the current state. I'll use the Duplicator plugin on your site.

I also need to know from you where is the code that outputs the custom fields to the Menu page. Can you please add this information here. And if you can also add the code, it can be great.

Thanks,
Itamar.

November 5, 2019 at 8:13 pm #4893515

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I've created a new and current copy of your site with the Duplicator plugin. And I've installed it on my local server.
Can you please tell me where in your theme's files, I can find the code that outputs the fields to the menu page?

Thanks,
Itamar.

November 6, 2019 at 9:51 am #4896379

martijnv-36

The code for outputting the menu content is located at "partials/02_molecule/m-food-content.php"

November 7, 2019 at 3:07 pm #4907361

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Thanks.

I've updated WPML plugins on your site.

With your site's copy on my local server in a minimum environment and after I redeliver the translations with the ATE, the content of the fields on the Menu page is showing. Please see the attached screenshot.
Could you please try the minimum environment on your site?
I suspect that there is a collision with the theme or another plugin that might cause this problem. If possible, get your site into a minimum environment. The minimum environment in your case means no plugins activated except WPML+ add-ons and ACF Pro.
Is it possible for you to try it?
Please also deactivate the Must-Use and Drop-in plugins on your site. Then redeliver the translation with the ATE, and check if the problem gets solved. If it does, then start activating the plugin one by one and check when the problem returns. The last plugin that you activated before the problem returns is probably the culprit plugin. So please tell me which one it is.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****


*** If your site is a live site, you might want first to try those procedures in a staging environment or a snapshot of your site on your local server or another server. ***

Thanks,
Itamar.

November 12, 2019 at 12:57 pm #4931857

martijnv-36

I deactivated all the plugins en activated all the WPML plugins, ACF pro and add-ons but unfortunately the issue is still not resolved. The delivered translation still doens't show up on the front-end.

If I provide a live copy of the website, could you maybe fix the problem on that copy so that I can migrate that to the original website?

November 12, 2019 at 5:44 pm #4933917

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Yes, please share with us the access to the copy of your site. For this, I'm enabling a private message for the next reply.

Thanks,
Itamar.

November 18, 2019 at 10:00 am