This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
May 7, 2019 at 10:18 am #3756311

Will

Our client is trying to translate content on their site, both manually and using a third-party translation service (using MemoQ) and when they try to save the translations, the content is reverting back to the English version.

I've recorded a quick screencast to demonstrate... hidden link

May 7, 2019 at 10:50 am #3756645

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

This was a known issue and it was fixed.
you are using latest WPML plugins. so it should work fine.

When you disable all the third party plugins and WPML Media then you try to save.
Do you see the same issue?

Let me know.

Regards,
Riffaz.

May 7, 2019 at 7:57 pm #3761671

Will

Hi Riffaz,

We've tried disabling all bar the core plugins required to operate (Advanced Custom Fields & the WPML plugins) on a local instance of the site, and the issue persists. I've attached an image of the active plugins.

If you could look into this further for us, that would be great.

May 8, 2019 at 6:44 am #3764083

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi Will,

You are facing this issue only in here hidden link right?

I am setting the next reply as private.
Let me know your site login details to check this closely.

Regards,

May 9, 2019 at 5:12 am #3773135

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

When I created hidden link and try to translated the page it works fine: hidden link
Could you please let me know the exact page where you have this issue?
Also, the steps to reproduce?

Regards,

May 9, 2019 at 8:31 am #3774195

Will

Hi,

The page from the screencast where I know for sure we're having the issue is the German version of this page... hidden link

When we try to update the Landing Page Single Column Title (as per the screenshot attached).

Cheers,

May 9, 2019 at 3:03 pm #3777489

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

You created that section using ACF and many of your systems fields are set to 'don't translate': hidden link (WPML > Settings > custom fields : show system fields" )
Find the correct custom field and mark it copy / translate.
You have so many and it will take some time find the one you are referring.
If it comes from theme, you can directly ask your theme support as well.
After you making it to copy/translate you should be able to translate it.

Also, after that increase your maxinputvars to 10000 and check the issue: hidden link

Let me know how it goes.

Regards,

May 16, 2019 at 9:18 am #3823629

Will

Hi Riffaz,

I've checked the ACF fields translations settings and I've increased the maxinputvars as suggested and the issue is still there.

Cheers,

May 16, 2019 at 11:01 am #3825161

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Then it should be something related to the plugin or theme.

We need to check this in a fresh installation.

please,
1. go to hidden link
2. install your theme
3. configure the ACF as you have
4. configure the WPML as you have it on your site. at the last step just click next (site key)
5. create only one page with element/field you are using.
6. recreate the issue.
7. let us know how to check this and how to recreate this issue.
8. explain the step 8 with screenshots and URLs for better understanding.

Regards,

The topic ‘[Closed] Translated content not saving’ is closed to new replies.