Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by zuzannaR 5 months, 2 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
September 11, 2020 at 4:54 pm #6996111

zuzannaR

Hi!

Can I please ask Mihai to look into this issue? He's already helped me with the problem I was having, but it looks like there's something wrong with the solution he gave me.

Here's the issue Mihail helped me with
https://wpml.org/forums/topic/wpml-chat-support-ticket-by-zuzannar-1598443705/

Here's the summary of the previous issue:
I had problems with inserting the Spanish sign up form on my translated page (it would change to the English form). Mihai duplicated my page and told me that from now I on, I shouldn't use the Classic Translation Editor for the translation of my Home page, but do it directly in Elementor: change the page language to Spanish and insert the desired translation.

Until here everything was fine - I was able to do it correctly and everything worked.

Here's my current problem:
I wanted to add something to my English Home page (primary language) and when I saved the changes in Elementor, I noticed that the Spanish Home page switched to English! Basically, the entire Spanish translation dissapeared from the Home page and was replaced with the English text.

I fixed it by pasting the Spanish text once again, but I don't want the Spanish content to dissapear everytime I update the English page. Any chance you could take a look at it?

Thank you and have a great weekend!

September 14, 2020 at 7:22 am #7005377

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi there.

My guess is that for the duplicate page, you might still have an option that's active which is causing that issue.

Please take a look at the following tickets's solution and see if that's the case:

- https://wpml.org/forums/topic/translations-being-overwritten-by-default-language-2/
- https://wpml.org/forums/topic/translations-being-overwritten-by-default-language/
- https://wpml.org/forums/topic/translated-content-gets-replaced-when-changes-are-made/

That should solve the issue.

Please let me know how that goes.

Kind regards,
Mihai Apetrei

September 14, 2020 at 10:55 am #7007647

zuzannaR

Hi Mihai,
That might be the issue! So just to make it clear, I need to do the following:
1. Go to the Home page of my secondary language, Spanish
2. Click on the Translate independently to unlink the Spanish version from the English one
3. Once done, if I update the English version, the Spanish one will not change automatically

Is that all or am I missing something?

September 15, 2020 at 7:56 am #7015537

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi there! 🙂

Perfect! You got that right.

That is true: after you unlink the translation, it should never be overwritten again when you update the default-language page.

Please let me know how that goes.

Kind regards,
Mihai

September 15, 2020 at 10:03 pm #7021537

zuzannaR

Wonderful - it worked! Thank you for your support, Mihai!