This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 7 replies, has 2 voices.

Last updated by Lauren 8 months, 2 weeks ago.

Assigned support staff: Lauren.

Author Posts
January 29, 2019 at 9:55 am

yvonnev-6

I am trying to: Translate my website and online course

Link to a page where the issue can be seen: hidden link the backend wants to go here for the lesson ... hidden link but the "/lesson/" part of the URL is changing to "/les/" automatically and won't display the content.

I expected to see: My translated lesson

Instead, I got: Sorry! Deze pagina is niet beschikbaar.

January 29, 2019 at 8:24 pm #3141591

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

The "les" was coming from the .mo file. I went to WPML -> String Translation and checked the box to use your translation instead and saved the changes. Then, I resaved permalinks. Now the URL is working correctly.

Please let me know if you need any further assistance and I will be happy to help.

January 30, 2019 at 12:19 pm #3143785

yvonnev-6

Thank you ...

This has solved the problem with the lessons, but not the course itself...

The link should be hidden link but it is changing it to hidden link automatically.

So I need the same fix to not change "/course/" to "/cursus/".

I went to WPML -> String Translation as you suggested but could not find the checkbox you refer to. Would you mind sending a screenshot of what you mean so I am able to do this in future myself?

Thank you.

January 30, 2019 at 4:20 pm #3144944

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Sure, I have attached a screenshot. I also updated the courses translations so it should be working correctly now. Please let me know if this is not clear and I will be happy to send additional information.

January 31, 2019 at 9:18 am #3146896

yvonnev-6

Hi Lauren

Thank you, you have been amazing ... okay the last (hopefully) stumbling block ...

Despite adding lessons and creating my Section and Lesson layout in the Course Builder, when I view the Dutch version of the course ... it says there are no sections ... hidden link

I searched in the String Translator section for section - and found the place but I don't have the checkbox saying "use my translation", my checkbox says "translation is complete" ... I have tried a few different settings here and it still doesn't save my Sections and Lessons layout in the Course Builder. The course builder for the Dutch course can be accessed here : hidden link

I hope you are able to assist to overcome this last hurdle.

January 31, 2019 at 6:09 pm #3149241

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Great, I'm glad we are making progress 🙂

The issue with the course info not showing up in the second language is separate from the slug issues. I don't think it will be solved via String Translation, but since this is a new issue, please open a new ticket so that we can focus on that specific issue, and not confuse too many problems in one ticket. Thanks for understanding.

I'll be happy to look into it if you would like me to split this ticket, or you can open a new one in the forum and get the next available supporter, which may be quicker for you. Just let me know either way. Thanks!

February 1, 2019 at 4:04 am #3150412
yvonnev-6

Please go ahead and split it.

New threads created by Lauren and linked to this one are listed below:

https://wpml.org/forums/topic/split-courses-not-appearing-in-second-language/

February 1, 2019 at 4:46 pm #3152487

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks, I have replied on the other ticket. You may mark this one as resolved.