This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by hans-jN 1 month, 3 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
August 20, 2019 at 5:23 pm

hans-jN

I am trying to: switch the language from German (main) to English.

Link to a page where the issue can be seen: hidden link

I expected to see: the translated pages

Instead, I got: an empty, white screen; no error messages in the console.
All pages, also the translated ones, are published.
The translated English pages use the same template as the original pages.
I saved permalinks.
The .htaccess looks like this:
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

I have no idea what's going wrong and hope you can help. Or tell me it is an elementor pro issue 😉

Regards
Hans

August 21, 2019 at 1:29 pm #4431829

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I took a detailed look in your website using your provided duplicator package and could fix the issue with these steps:

1 - In increased your current WP_MEMORY_LIMIT from 128M to 256M and WP_MAX_MEMORY_LIMIT from 256M to 512M in your wp-config.php file.

2 - Then, I made a minor editing in your default language content (here you can add a period or an empty space for example) then I saved it in order to force a refresh in the translations jobs.

3 - I edited the translation in order to check them as 100% complete and saved them again.

See: https://wpml.org/documentation/plugins-compatibility/elementor/

Please, let me know if these steps work for you. Have a nice day.

August 21, 2019 at 3:33 pm #4433223

hans-jN

Hi Marcos, thanks for the fast reply!

I successfully followed step 1 and increased the memory limit successfully: The 256M and 512M are reported in the system info.

I re-wrote a page (not just a minor edit ;-)and saved it. The translations jobs refreshed (I guess you mean the pencil changed to the arrow circle, right?)

I clicked that icon and the Advanced Translation Manager opened. I accepted all automatic translations (100% reached) and finished. The pencil showed up, but no English page is reported, the language switcher (added as short code in the first section of that page) does not show the EN flag. And, as expected, checking the address under /en/ does not find anything.

So, I must be missing something very basic, because there isn't the "+" in the edit window; as I would expect; following the video.

I think my question is:
How can I make use of the Advanced Translation Editor (or at least an editor that allows making use of the same automatic translation option)?
AND
use elementor to make see the layout and make use of the nice feature I've seen in the video.

I guess I made a setting (based on a wrong assumption and misunderstanding) that blocks exactly that.

Please let me know what the suggested setup is so I achieve a workflow as shown in the video; with the option of automatic translation!

Thanks a lot; I', looking for a solution and hopefully easy answer 😉

Regards
Hans

August 21, 2019 at 3:44 pm #4433843

hans-jN

Additional information:
I created a new page, and that looks much better!
- I built that page with elementor and saved it.
- I then saw the "+" sign and clicked it; and could automatically translate
- I saw both flags (EN and DE) and could switch, and the correct EN page shoed up.

I assume that it is necessary to enable Advanced Translation Editor before creating a page!?

Now that I know I could live with that.
But if you have a suggestion how I could get into the same stage (i.e. seeing the "+") with a page that already exists would be highly appreciated!!

Thanks!

August 22, 2019 at 1:56 pm #4439931

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Regarding your questions:

1 - "I guess you mean the pencil changed to the arrow circle, right?"

Yes, this is what I mean, when you refresh a translation, in other words when your make an editing on a page in the default language, then translated page will show a 'arrow circle' icon indicating you need to update your translation.

2 - "How can I make use of the Advanced Translation Editor (or at least an editor that allows making use of the same automatic translation option)?"

Basically the worflow is the same provided here: https://wpml.org/documentation/plugins-compatibility/elementor/

2.1 - As a first step you would need to enable the Advanced Translation Editor in your WordPress Dashboard > WPML > Settings > How to translate posts and pages settings.

See: https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/activating-the-advanced-translation-editor/

2.2 - Now, in your WordPress Dashboard > Pages you can click to edit your page and add a translation for it.

See: https://wpml.org/documentation/plugins-compatibility/elementor/#Translating-Elementor-pages-with-WPML

3 - "I must be missing something very basic, because there isn't the '+' plus icon in the edit window"

3.1 - You will only see a plus icon '+' for those pages without a translation, for the pages already translated you will see an arrow circle icon for the pages that needs and update for its translations or a pencil icon for editing a page already translated.

3.2 - If you need to see a plus icon again to start over a new translation you would need to delete your current translation, something you can make as you would delete any other page or post. Here are the specific instructions:

3.2.1 - Click to list all the pages in your WordPress Dashboard > Pages

3.2.2 - Change to your secondary languages using the language switcher from the top admin bar.

3.2.3 - Now check the page translation you need to delete and move it to the trash.[

3.2.4 - Then, click the trash link and delete the translation permanently.

Now you should see the plus '+' icon again, indicating your page doesn't have a translation yet.

4 - "I assume that it is necessary to enable Advanced Translation Editor before creating a page!?"

4.1 - It is not necessary to enable the translation editor before creating a page in your default language, actually the order here won't matter, you can activate it and then create your original language page, or you can create your page and then activate it, but it for sure needs to be activated before adding a translation.

Please, let me know if you need any further clarifications and instructions. Have a nice day.

August 22, 2019 at 9:10 pm #4442907

hans-jN

Hi Marcos,
thank you very much for the excellent summary and detailed step-by-step explanation!

After I worked with some more test pages (create new ones, modify existing ones, delete the pages, delete the seondary page only, watch the icons , switsched languages) I could fully understand and follow your points! And more or less came to the same conclusions!

So we are on the same page and I think I now got a pretty good knowledge (and feeling) about what to do; and when and how. And your summary will be is a perfect summary and overview whnever I have question or doubt again.

Before I close this issue as resolved (I would do so right now, but think I must keep it active so you can answer) I'd like to get your help on a final question:

I saw a nice mode in the video, that I could not get with my setup:
The elementor view with the sections in the main language on the left and the same sections with the second language on the right.

At the end it offers the same functionality as the Advanced Translation Editor, but it seems to be a more visual representation and therefor in certain cases easier to use.
So my question is:
Is this another Translation Editor? Do I hve to install a special plugn for that? Where would I find that plugin? How to set it up?

Hopefully I could explain clearly enough what I'm looking for, so you can help me!

Regards
Hans

August 22, 2019 at 9:23 pm #4442981

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates, I am glad my instructions helped you to figure out the translation process. regarding your questions, the video shoes the WPML Standard Translation Editor, you can activate in your WordPress Dashboard > WPML > Settings > How to translate posts and pages. It has a more 'WordPress like' interface and provide the basic features to get your pages/posts translated.

See: https://wpml.org/documentation/translating-your-contents/translation-tools-available-with-wpml/

Hope it helps to clarifies your questions, have a nice day.

August 22, 2019 at 11:40 pm #4443149

hans-jN

Thank you so much!
I think I got it 😉
You helped saving me a lot of time and making me feel better; great support!

Regards
Hans

August 22, 2019 at 11:42 pm #4443151

hans-jN

My issue is resolved now. Thank you!