This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Mihai Apetrei 1 year ago.

Assigned support staff: Mihai Apetrei.

Author Posts
October 4, 2018 at 9:49 am #2787079

Pierre-André Aebischer

I am trying to:
translate a page

Link to a page where the issue can be seen:
hidden link

I expected to see:
a french version in pages

Instead, I got:
nothing

October 4, 2018 at 5:36 pm #2788406

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

From what I can see, there's no translation for this page and whenever I try to access it, there's a redirection happening that sends me to the home page (this is the default behaviour due to the current setup under the WPML > Settings > Post Types Translation where Pages is set to "Translatable - only show translated items").

I see that you are using the Enfold theme on your site and that the content blocks are built using the Avia content builder so here is a very useful documentation page written specifically for people who use this theme:
https://wpml.org/documentation/theme-compatibility/enfold/

I hope you will find this useful.

Please let me know if that solved your issue or if you still need help.

October 4, 2018 at 7:19 pm #2788667

Pierre-André Aebischer

Hi Mihail, yes thanks for noticing,

this is the issue, I did the translation, from scratch from the original english page, it even says "translation complete" in WPML Translation queue page, but as you have noticed the translated page is nowhere to be seen. It seems as if it has not been created at all by WPML.

Then if I try to create another translated page from scratch in WP, i have no mean of forcing the connection in the Language dialog in the WP Page editor, as the relink dialog is missing.

(May I had that a Google search returns tons of similar enquiry, but none yet answered)

Any idea? Txs, kind regards, Pierre-André

October 8, 2018 at 6:29 am #2794821

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

I see.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

The topic ‘[Closed] Translated EN page (customers) not created in FR’ is closed to new replies.