Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 4.56 hours from now. Thank you for your understanding.

This topic contains 17 replies, has 2 voices.

Last updated by logarajahT 2 months ago.

Assigned support staff: Bigul.

Author Posts
January 11, 2020 at 7:26 am #5272917

logarajahT

I am trying to:
Receive gravity form notification email for the translated zh-hans Chinese form
Link to a page where the issue can be seen: hidden link

The English link is: hidden link

I expected to see: Image 2 as captured in gravity forms entries

Instead, I got: image 1 no data from the notification email

FYI, We just added the translation on Monday this week. And this was the first form entry we received.

Please advice fix. Thanks.

image2 rc zh-hans gf entry with data data.JPG
image1 rc zh-hans gf notification email - no data.JPG
January 13, 2020 at 7:47 am #5279591

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve the issue.

I hope you are using WPML Translation Editor for translating the Gravity Forms. Please check the following documentation for more details.

https://wpml.org/documentation/related-projects/gravity-forms-multilingual/#translating-gravity-forms

Are you using any custom shortcodes in the Gravity Form Email notification? Please share with me the screenshot of the English Gravity Form notification mail for a better understanding.

--
Thanks!

Bigul

January 13, 2020 at 10:51 am #5280927

logarajahT

Hi Bigul,
Thanks. All the forms have been translated already by ATE. I cannot find the translated versions to edit.

Enclosed is the notification email for the gravity form.

What needs to be done to fix this please/
Thanks, Logga

image3 gf notification email setting in english.JPG
January 13, 2020 at 3:47 pm #5284315

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Logga,

Thank you for the updates. Please try the following steps and check is there any difference in the result.

1) Open the Gravity Form edit
2) Make a minor change in the form and save the changes(to refresh the translation settings)
3) Visit WPML>>Translations
4) Open the translation for edit from the Translation Queue
5) Make sure you have correct translation for the notification message
6) Update and complete the translation

--
Thanks!

Bigul

January 14, 2020 at 4:32 am #5286725

logarajahT

Hi Bigul,
Thanks. I've now identified the issue. WPML is converting GF shortcodes written in {original language} to be [target language] in the notification email. Once I've changed it {original language} to be {original language}, in the translated form, it works fine in the notification email.

Please refer to enclosed screenshots. Could advice when WPML can update their plugin to reflect correctly please?

Thanks, Logga

wpml translation of gf form biz corrected with curly braces.JPG
wpml translation of gf form biz.JPG
January 14, 2020 at 1:59 pm #5290279

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Logga,

Thank you for the updates. Please share a little more about the following. Because I am bit confused about this.

Could advice when WPML can update their plugin to reflect correctly please?

Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

January 15, 2020 at 1:24 pm #5297769

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Logga,

Thank you for the login information. But I am not able to access your site because of the permission settings. Please check the attached image for more details.

The result is the same after trying from different connections. May in your security settings the site is blocked for India.

--
Thanks!

Bigul

2020-01-15_1833.png
January 15, 2020 at 2:50 pm #5298717

logarajahT

Sorry about that Bigul.
I've unblocked for India now.
Please try again.

January 16, 2020 at 7:40 am #5303491

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Logga,

Thank you for the updates. I can access and login to the site now. Please note, I set myself as a Translator and Translation Manager in WPML settings to access the Translation Jobs list and hope it will be okay for you.

As a part of our escalation procedures now trying to reproduce the issue in a minimal setup. We will get back to you soon. Please wait.

--
Thanks!

Bigul

January 16, 2020 at 2:07 pm #5305925

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Logga,

I have tried it a few times in my test installation but not able to reproduce the issue exactly. Please check the attached images. So one doubt. Does it happen when you translate the Gravity Forms by using the *Translated automatically* feature of WPML Advanced Translation Editor? I mean the following.

WPML is converting GF shortcodes written in {original language} to be [target language] in the notification email.

--
Thanks!

Bigul

2020-01-16_1911_001.png
2020-01-16_1911.png
2020-01-16_1910.png
January 16, 2020 at 2:14 pm #5306017

logarajahT

Hi Bigul,
Yes, I used the translate automatically feature.
So what needs to be done next please?

And do you still need the access?

Thanks, Logga

January 17, 2020 at 8:22 am #5310275

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Logga,

Thank you for the updates. I have reproduced the issue and escalated the ticket to our developers for fixing. We will get back to you soon when we have an update on this. Please wait.

You can change the security settings. We don't need the access for now.

--
Thanks!

Bigul

January 17, 2020 at 1:49 pm #5312417

logarajahT

Thanks Bigul.
Looking forward to your update then.
Thanks, Logga

January 18, 2020 at 12:39 pm #5315803

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Logga,

Thank you. We will get back to you as early as possible. Please wait.

--
Thanks!

Bigul

February 4, 2020 at 2:18 pm #5422109

logarajahT

Hi,
Could someone advice is this matter is resolved please?
Thanks, Logga