Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Spanish Homepage returns a 404 error

Solution: Spanish Homepage returns a 404 error and it works fine for other secondary language. It was happening because somehow it seems like the Spanish version of the Homepage lost its connection to the homepage settings in Enfold>>Theme options>>Frontpage Settings. Setting it again has fixed the issue.

Relevant Documentation: https://wpml.org/wp-content/uploads/2019/12/5197227-wpmlSnip7.jpg

This topic contains 18 replies, has 2 voices.

Last updated by Richard Canny 1 month, 2 weeks ago.

Assigned support staff: Bigul.

Author Posts
December 23, 2019 at 8:05 pm #5186149

Richard Canny

I am trying to: Keep my translated site running normally.

Link to a page where the issue can be seen: hidden link

I expected to see: My homepage in English translated to Spanish

Instead, I got: 404 error

December 24, 2019 at 7:24 am #5188409

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve the issue.

Does it happen for the admin users also? Please make sure you have published the Spanish homepage translation.

Please try the following steps and make sure is there any difference in the result.

1) Visit WPML>>Languages>>Language URL format
2) Resave the settings
3) Visit Settings>>Permalink Settings
4) Resave the settings

--
Thanks!

Bigul

December 24, 2019 at 2:39 pm #5189747

Richard Canny

Hello Bigul,
I re-saved the permalinks as you suggested without success.
The problem occurs for admin users as well as for public users of the site. Yes, we have double checked that the Spanish homepage has been translated and published. I've included snips of the page status and the page opened in the editor.
Would you like a logon to our wordpress back end so you can examine further?

Thanks for your help!

December 25, 2019 at 5:39 am #5191993

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

December 25, 2019 at 6:54 pm #5193069

Richard Canny

Thanks, I have sent the logon for worpdress and also FTP access.
Thanks,
Richard.

December 26, 2019 at 7:29 am #5194951

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Richard,

Thank you for the login information. I had a quick check and settings look fine. Therefore please tries the following troubleshooting steps after a full site backup and make sure the issue is existing or not.

1) Upgrade to the latest version of WPML 4.3.6

2) Make a minor change to the default language homepage and update it(to refresh the translation settings)

3) Update the translated Homepages

4) Go to WPML>>Support page

5) Click on Troubleshooting link (blue link in the middle of the page)

6) In the Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Assign translation status to duplicated content
- Fix post type assignment

If the issue exists, if possible please switch to the default theme or Enfold parent theme for a moment and check the problem remains or not.

--
Thanks!

Bigul

December 26, 2019 at 1:09 pm #5195911

Richard Canny

Good morning Bigul,
Thanks for your help. I've taken all those steps, and unfortunately the problem still exists. Changing the theme made no difference. I cleared the cache also to check this. Please let me know the next steps. Thanks!
Richard.

December 26, 2019 at 1:12 pm #5195981

Richard Canny

Update: Now when I change the theme back to our Enfold Child theme, it seems to be working. I'll provide more information shortly. Thanks!

December 26, 2019 at 1:23 pm #5196043

Richard Canny

I see now what it is doing. The home page url ultimationinc.com still returns a 404 when switching to spanish with the flag switcher. However, WPML is creating duplicate home pages in english of ultimationinc.com/home-2-2/ and portuguese of ultimationinc.com/pt-br-inicio-2-2/
The spanish version of that page has a system generated url as shown in the snips.

I've attached snips of the new page that WMPL has created in all three languages. These pages never existed previously and it looks like WMPL is creating them?
Please review and let me know next steps.
Thanks,

December 26, 2019 at 1:48 pm #5196189

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Richard,

Thank you for the updates. There is a change in Settings>>Reading and *Your latest posts* option is selected for *Your homepage displays* option. That is why the URLs are changed in the *Conveyor Manufacturers – Automated Conveyor Systems* and there is no duplication for the Homepage also. Please check the attached images for more details.

Just make sure, you have got the expected result which switching between Enfold parent theme and child theme?

--
Thanks!

Bigul

December 26, 2019 at 1:58 pm #5196245

Richard Canny

Hello Bigul,
Thanks for pointing out that setting. However when I went to that setting on my backend, it was already selected to go to the static home page. I still have the original problem with a good homepage in english and portugues but a 404 in spanish. Any next steps?
Thanks,

December 26, 2019 at 2:06 pm #5196277

Richard Canny

By the way, I notice that when I am editing the spanish homepage ultimationinc.com/es everything looks find in the editor, but I can't even preview the page in wordpress.

December 26, 2019 at 3:45 pm #5196717

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Richard,

Thank you for the updates. Please open the Spanish homepage in the native WordPress editor(like the following Image) and save the Page. Then make sure is there any difference in the result or not.

https://wpml.org/wp-content/uploads/2019/12/5196043-wpmlSnip3.jpg

If the issue exists, please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

December 26, 2019 at 4:06 pm #5196793

Richard Canny

Hello Bigul,
Yes, I tried re-saving the spanish page, but no success. I have installed the duplicator plugin, but I am having trouble getting the package built (Getting error 524). Would you be able to login to worpdress and build the package yourself?

December 26, 2019 at 4:09 pm #5196795

Richard Canny

Can you use UpdraftPlus? Looks like we have that already on our site. THanks