Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:
My site is showing blog posts instead of the translated homepage. No issue with the default language. Everything is configured correctly. I'm using Microsoft-IIS server.

Solution:
Make sure that there's no issue with the rewrite rules on your Microsoft-IIS server.

When using "Pretty Permalinks" in WordPress, this should be configured accordingly in the web.config file.

As a test, find a web.config file located in the root directory of the installation, open it and change temporarily its content to this default one:

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
  <system.webServer>
	<rewrite>
		<rules>
			<rule name="Main Rule" stopProcessing="true">
				<match url=".*" />
				<conditions logicalGrouping="MatchAll">
					<add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true" />
					<add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true" />
				</conditions>
				<action type="Rewrite" url="index.php" />
			</rule>
		</rules>
	</rewrite>
 
  </system.webServer>
</configuration>

If "Pretty Permalinks" is working fine, then everything else should work fine with the WPML plughin.

Relevant Documentation:
http://www.iis.net/learn/extensions/url-rewrite-module/enabling-pretty-permalinks-in-wordpress

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 25 replies, has 3 voices.

Last updated by Andrey 5 years ago.

Assigned support staff: Andrey.

Author Posts
May 30, 2016 at 1:25 pm #892950

Giancarlo

I am trying to translate my company website from english to german
URL of (my) website where problem appears: hidden link
I expected to see: the translated homepage. Instead, it shows the blog page

If i set the URL format as Parameters it works, but I need to have the URL as hidden link, so in the Directories mode

I read a lot and everywhere they say this issue will be fixed in next release, the 3.3.8. I have this release already. So it has not been fixed?

May 31, 2016 at 3:55 am #893330

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Thank you for contacting WPML support.

The issue that you are talking occurs when "language used as a parameter" and will be fixed in next release as well as the fixed is already released in the beta version.

Your issue seems to be different as the issue is occurring on directories mode. So to further debug this issue, could you please check if this issue appears when

#1
All WPML plugins are updated to the latest version.

NOTE:

+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!). You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose. See: http://wordpress.org/plugins/duplicator/

#2
All non WPML Plugins are disabled. It will tell us if there is an interaction issue with other plugin.

#3
Theme is set to a WordPress default like Twenty Fourteen. Its will tell us if there is an interaction issue with your theme.

I will wait for your feedback.

Thanks

May 31, 2016 at 12:51 pm #893805

Giancarlo

Hello Shekhar, thank you for your reply.
At the moment I am updating WordPress to the latest version, maybe this will fix everything.

I have a doubt: If I change template, when I will get back to the current one, will I lose all the modifications that I did to its php and css files? Since I made many of them to adjust the contents and appearance..

Disabling and re-enabling plugins will keep all the data too?

I am really afraid to make such big changes and not being able to get back since it's my company website

May 31, 2016 at 2:20 pm #893891

Giancarlo

Update: I tried both your suggestions but they didn't change it..

#2 Please see the screenshot of the translated homepage with no plugins enabled, as you can see tit still shows the blog page

# 3 Please see the screenshot of the website "wearing" the Twentyfourteen - still the translated page is wrong while the English one is correct

For these tests I am using another website - since I could to the full backup of this one faster than the other one - It has the same problems reported in my first post, the "Parameters" way is working fine and the "directories" is not

plugins-disabled.jpg
default-theme.jpg
June 1, 2016 at 6:59 am #894304

Giancarlo

Hello Shekhar,
I created an account, in case you can go and take a look by yourself to the settings of the plugin.

As extra information:
- I installed no other WPML plugins, only WPML multilingual CMS
- In the "Theme and plugins localization" area I have a "File Exists" in the /wp-content/languages folder, while I have a "File not found!" in the theme folder: can it be the cause of my problem?

June 1, 2016 at 9:34 am #894432

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

These info is private, and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

I will wait for your feedback.

Thanks

June 2, 2016 at 3:13 am #895128

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

I tried to replicate your site on my localhost, and I am not able to replicate this problem, so could you please let me know if you are using any cache plugins or if your host is using cache service, if so, could you please create all the cache and test the issue and let me know if this solves the issue.

I look forward to your reply.

Thanks

June 6, 2016 at 7:35 am #897769

Giancarlo

Sorry I don't understand what you mean with "create all the cache". We have an external server

Did you have chance to take a look at the live site's settings and plugins? were they all ok?

June 6, 2016 at 8:33 am #897824

Giancarlo

I disabled the caching in the server, but the problem is still there

June 6, 2016 at 10:53 am #897967

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

In order to be better help, I have escalated this ticket to 2nd tier support, one of the 2nd tier supporter will respond to you soon.

Thanks

June 6, 2016 at 12:34 pm #898057

Giancarlo

Still both of our websites are hosted by the same provider, could it be a server-related issue? I hope this issue to be solved soon.

June 6, 2016 at 12:34 pm #898058

Giancarlo

Since both of our websites - which have the same problem - are hosted by the same provider, could it be a server-related issue? I hope this issue to be solved soon.

June 7, 2016 at 7:18 am #898658

Giancarlo

Hello, who is being in charge of my support? I still need assistance please

June 8, 2016 at 8:38 am #900665

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

I just received an feedback from the 2nd tier support.

Could you please make sure to update your PHP version to 5.6 which is minimum requirements for the plugin or try alternative hosting if possible, https://wpml.org/home/minimum-requirements/

Please let me know if updating the PHP helps you to solve the issue. I look forward to your reply.

Thanks

June 8, 2016 at 8:52 am #900685

Giancarlo