If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Translated images don't always show up in media library and posts

Solution: The issue was only happening with different domains per language and the image wasn't loaded properly with the additional domains, contacting the hosting provider solved the issue.

This topic contains 29 replies, has 2 voices.

Last updated by jean-paulS 3 months, 1 week ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
July 31, 2019 at 8:57 am #4313079

jean-paulS

Update: I must be forgotten yesterday to save the "different domains per language," or the setting was reversed somehow because I saw now that it was still set to "different languages in directories." When choosing "different domains per language," the problem is still there (again).

July 31, 2019 at 9:25 am #4313269

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I just checked your both URLs and it doesn't look to be configured properly, could you please let me know how you have configured this domain, are these parked domains?

Look forward to your reply.

Thanks

July 31, 2019 at 9:27 am #4313275

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Also, search this page for " No email notifications" this is in the header of the forum and change this to receive email notifications.

Thanks

July 31, 2019 at 12:50 pm #4314433

jean-paulS

yourindiverse.net is the primary domain, and jouwindiversum.net is a parked domain.

August 1, 2019 at 3:55 am #4318613

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I checked the IP for these sites using ping Sitename and they are pointing to different places, also when the domain is parked it shows the exact content from the original domain but on your case, it's showing a maintenance mode so can you check it again and see if it's configured properly.

Look forward to your reply.

Thanks

August 1, 2019 at 6:54 am #4319099

jean-paulS

Hello Shekhar,
I enabled the maintenance mode yesterday because I discovered that Google Search indexes my website though I checked "Discourage search engines from indexing this site." But I forgot that this way, you can't access the Dutch part of my site from "outside." So, I disabled it again. Sorry for the inconvenience.

August 1, 2019 at 7:09 am
August 1, 2019 at 8:28 am #4319725

jean-paulS

Hello Shekhar,
I will contact my host provider about these issues because the ftp account isn't working indeed though I checked the details. I also can't open the admin panel of the staging site I created in cpanel, and earlier attempts to create a test site with different staging plugins also failed. And the different IP addresses is also something I can't figure out myself. I will contact you again as soon as I know more.

August 1, 2019 at 7:59 pm #4324999

jean-paulS

Hello Shekhar,
About the IP addresses: they are different because my real IP address is hidden by Cloudflare. If you need the real address, I can send it via a private message.
For the FTP account, you have to use FileZilla or a similar application with a hostname I can send you too via private message (and which I forgot to give you). Username and password are still the same I gave you earlier.
I had some trouble opening the admin panel of my staging site, and Siteground solved the problem, but I have to change some more settings. I will give you the credentials as soon as I have them.

August 2, 2019 at 4:02 am #4326641

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Sure, keep us updated.

To send the updated details you can edit your previous private replies and send the details.

Look forward to your reply.

Thanks

August 6, 2019 at 6:54 am #4344515

jean-paulS

Hello Shekhar, there were some more issues with the staging site, but finally, Siteground Tech support managed to solve them yesterday. So I updated the details about my IP address, my FTP account, and the staging site. All plugins from the latter are disabled as you asked, except for the WPML plugins, the Classic editor which can't be deactivated and the Content Aware Sidebars plugin, because disabling it makes my sidebars a mess. Unless the staging site has to be pushed to live, you can disable it too. See you later on today or tomorrow… (I'm not at my PC all day).

August 6, 2019 at 6:56 am #4344525

jean-paulS

(The update of the credentials are in the private message of July 25, 2019 at 10:14 am)

August 6, 2019 at 11:56 am #4347087

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I tried to log in to the staging site using the link but it asks for username and password (web protection) Could you please provide me these details too.

I have enabled the private reply so you can send me the updated details in the next reply.

Thanks

August 6, 2019 at 7:58 pm
August 7, 2019 at 3:52 am #4351939

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The different domains per language will not work on the staging site as the stating site URL and the NL language URL is not configured properly. If you went to WPML->Languages->Languages URL format, and save the domains you will receive not a valid message.

Being so, is it ok to debug the issue on the live site itself, you can create a backup and we can proceed further.

You can edit your previous private reply to send the updated details for the live site.

Thanks