Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by patrickA-11 10 months ago.

Assigned support staff: Jamal.

Author Posts
February 8, 2019 at 11:39 am #3174844

patrickA-11

Thank you Jamal, it worked!

But now that I can see it in english, I notice that the incoming address and the footer text do not change even though their strings have been translated. Could there be some missing code?

February 8, 2019 at 11:49 am #3174874

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for contacting WPML Support. I will be glad to help with this.

Please update all WPML plugins to latest release after a full backup.

Can you tell what email have you tested and presents this issue ? Is it happening with all WooCommerce emails ?

If possible, allow me access to debug this issue further. Please fill the private details fields after a full site backup. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Best regards,
Jamal
WPML Support

February 12, 2019 at 3:58 am #3186525

patrickA-11

With the private info I have sent you for another problem, would you be able to look at this one too?

I have only tested the "lost password" email and "note to client".

February 12, 2019 at 12:09 pm #3188352

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Sorry, i could not reproduce this to check it, i could not receive a lost password email in jamal.b(at)onthegosystems.com.

So i installed the WP Mail Logging plugin to catch emails, but this could not reveal the incoming address. I found a string that was not translated, and i searched for it and translate it, then it was reflected in the email. See attached images for before and after i translate the string in WPML->String Translation, note the selected text in search box. Check both emails to see the difference before and after translation.

I also installed the File Manger plugin to check theme files if they have overridden the emails templates. But it is not the case.

If you can please forward an email to my address, so i can see the incoming address, and also specify what address should be instead.

Best regards,
Jamal
WPML Support

February 12, 2019 at 12:16 pm #3188415

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I just received an email from outilspourlavie(at)outilspourlavie.com in french, with subject in french
Subject: [Outils pour la vie] Votre identifiant et votre mot de passe
Body:
Identifiant : jamal

Pour configurer votre mot de passe, rendez-vous à l’adresse suivante :

<hidden link;

hidden link

February 12, 2019 at 2:41 pm #3189275

patrickA-11

Hello Jamal, I just realized that your prefered language was french, so I switched it to english...

February 12, 2019 at 4:04 pm #3189703

patrickA-11

I just realized, by delving in another unrelated problem, that in my smtp plugin, there were checked options that prevented the from-name and the from-email address from being modified...

It seem to be ok now, the only thing missing is the footer translation...

February 12, 2019 at 4:12 pm #3189742

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I have tested again, after you changed my preferred language, and i got the email in french when i tried to reset password from french. And i got an email in english when i tried to reset my password from english website(Account page).
Both mails seems in the right language, except the picture in the footer of the mail. This is actually a picture.

You will need to create another picture which have a text in english, upload it to your website. Then locate and translate the footer image, using XML configuration or through WPML->String Translation->Translate admin strings. I can help with this. But the login info in the previous ticket were removed, i will need you to send login info again.

If you find it difficult to translate the image, upload the english image, and let me know, i will check it.

Best regards,
Jamal
WPML Support

February 13, 2019 at 2:30 am #3191591

patrickA-11

hidden link

You can use your email to make a lost password request and get back in.

My picture is inserted as html, it is basically a text field.

February 13, 2019 at 2:32 am #3191604

patrickA-11

here's a pic!

February 13, 2019 at 9:48 am #3192932

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

This is not yet translated, because you did not check the "Traduction teminée" in your last screenshot. I just made another test, but i did not receive the email yet.

Can you check the option and test again ?

Best regards,
Jamal
WPML Support

February 13, 2019 at 5:34 pm #3195667

patrickA-11

Well, DAYUM!!! That was it!? I still don't get it, LOL, but thanks! Might the translation have undone itself? ANyways... I'll keep an eye on the mention "This translation needs an update". I probably wasn't paying attention to it.

Thanks again for your dedication and patience 🙂

February 13, 2019 at 6:39 pm #3195814

patrickA-11

My issue is resolved now. Thank you!