This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Bigul 3 months, 2 weeks ago.

Assigned support staff: Bigul.

Author Posts
June 21, 2019 at 7:36 am #4065223

markW-10

Hi,

On this page: hidden link the team members are shown. They have been translated to EN but are not showing up in the EN translation. Did I forget something?

June 21, 2019 at 4:30 pm #4068379

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

This may be happening because of caches or sync issue. Please try the following troubleshooting steps after a site backup and make sure the issue is existing or not.

1) Go to WPML>>Support page

2) Click on Troubleshooting link (blue link in the middle of the page)

3) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
- Recreate ST DB cache tables

--
Thanks!

Bigul

June 23, 2019 at 1:56 pm #4073151

markW-10

I did all of this but they're still not showing.

June 24, 2019 at 7:18 am #4075011

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

June 24, 2019 at 1:56 pm #4077749

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information. This may be happening because of the *mk_employees* shortcode. This shortcode is using the IDs of Employee posts to list it on the Team Members page. So translating the IDs value will fix the issue. I have added language configuration for it in WPML>>Settings>>Custom XML configuration. Please check the attached images and following documentation for more details.

https://wpml.org/documentation/support/language-configuration-files/#page-builder-content

Please try the following steps and check you are getting the expected result or not.

1) Update the *Ons team* page after a minor edit to refresh the translation settings
2) Open the *Ons team* page translation for edit in WPML Translation Editor
3) Translate the Post IDs by using the English Employees Post IDs
4) Save the translation

--
Thanks!

Bigul

June 27, 2019 at 7:38 am #4097353

markW-10

I did the translation of the employees but they are still not showing. Only one of them is showing all of the time.

June 27, 2019 at 7:44 am #4097399

markW-10

I fixed it by not using the ID's but categorie to show

June 27, 2019 at 3:03 pm #4101131

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Happy to know the issue is resolved now. Please let me know if you need any further assistance.

--
Thanks!

Bigul

The topic ‘[Closed] Translated items not showing’ is closed to new replies.