Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by osamuW 2 years, 2 months ago.

Assigned support staff: Lauren.

Author Posts
March 2, 2019 at 2:26 am #3263635

osamuW

I am trying to: put the translated logo on French site.

Link to a page where the issue can be seen:hidden link

I expected to see:French logo that I uploaded.

Instead, I got: Still English logo

String translation logo.jpg
March 4, 2019 at 2:47 pm #3269363

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Please check in the admin texts for a string that has the logo image ID. I believe this is the string that needs to be translated, and you can enter the ID for the French logo in WPML -> String Translation. Please see this similar ticket and the screenshots that can help walk you through this: https://wpml.org/forums/topic/logo-replacement-on-astra-theme/#post-2407068

Please let me know if you need any further assistance and I will be happy to help.

March 4, 2019 at 3:24 pm #3269554

osamuW

Thanks for your quick reply. As you can see attached the screen. I could identify the image ID. But I cannot find the string for the logo image under WPML -> String Translation. Can you chat and troubleshoot this issue?

add translated logo image.jpg
March 4, 2019 at 4:57 pm #3270062

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Usually this means that you need to increase Max Input Vars in order to have the string added. Alternately, you can go to WPML -> Settings -> Custom XML Configuration and add the admin text there, following the instructions from here: https://wpml.org/documentation/support/language-configuration-files/

You can increase maxinputvars by adding this line to your .htaccess file:

php_value max_input_vars 20000

or by following these steps:
1. Connect to your site via FTP or File Manager
2. Navigate to wp-admin folder
3. Create a file inside wp-admin folder called php.ini
4. Add in this line: max_input_vars = 20000
5. Save

If you don't have access to these files, please ask your hosting provider to do this for you.

March 4, 2019 at 6:49 pm #3270404

osamuW

I created the php.ini file and followed your suggestion. But it is not working. Should I increase the number?

March 4, 2019 at 7:40 pm #3270505

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

March 6, 2019 at 1:51 pm #3279364

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for allowing me access. I added the following to WPML -> Settings -> Custom XML Configuration:

<wpml-config>
  <admin-texts>
    <key name="theme_mods_astra-child">
      <key name="custom_logo"/>
    </key>
  </admin-texts>
</wpml-config>

Now when you go to String Translation, you can see the logo ID and you can add the translated ID.

Please let me know if you need any further assistance and I will be happy to help.

March 26, 2019 at 3:45 pm #3464227

osamuW

My issue is resolved now. Thank you!