This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Andreas W. 3 months, 3 weeks ago.

Assigned support staff: Andreas W..

Author Posts
June 20, 2019 at 9:31 am #4058127

jasonL-38

I have sent a number of materials to my colleague internally for translation. When he has completed the translation it's status changed to Needs update and not Completed in the 'Translation Jobs' status.

If I then go to the translation management tab it also shows the icon for needs update.

Finally I go in to edit the 'product' in this case and open up the product page click on the gear icon to update the translation via WPML's Advanced translation editor and it looks like all my colleagues translations have disappeared.

June 20, 2019 at 11:06 pm #4063551

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

Could you please increase your Memory Limit and WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 256M
WP Memory Limit 40M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great. It is actually advisable to have the PHP Memory Limit assigned to a higher value than the WP Memory Limit. You should be able to change the limit inside of the php.ini or the htaccess file.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means, with a default theme and not other plugins installed.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.

Add the following to your wp-config.php file:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */

You will be able to find a complete report inside of your wp-content folder in case of present errors. Look for a debug.log file and provide me the results.

More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Kind regards
Andreas

The topic ‘[Closed] Translated material comes back as 'needs update'’ is closed to new replies.