This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Lauren 1 year, 5 months ago.

Assigned support staff: Lauren.

Author Posts
April 24, 2018 at 9:14 am

veggekko

Hi all.

I setup everything according to this instruction:
https://wpml.org/de/documentation-3/ratgeber-zum-loslegen/media-translation-modul/

Then I clicked the "Start" button in the settings area to duplicate all media.
Then I used the Media Manager to translate my alt tags.

Then I replaced the english images on the edit pages of the german page with the german image. [It seems like I had to do this step, which I actually do not understand as the system could automatically use a translated image if available - would be more logic and easier I guess].

Then I saved the page and loaded the front end.
All fine: EN alt tags on EN page. DE alt tags on DE page.

At a later point one of the translators clicked on the little pencil icon to translate some of the content [using the translation screen with the text fields in 2 columns]. After he was done he hit safe ... and the DE version was showing the EN alt tags again.

How to prevent that?
Thanks

April 25, 2018 at 1:12 pm #1810244

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

I believe this is happening because you have selected to duplicate the media, so when you save the translation, the English content is being duplicated (or copied) to your translation. Please try unchecking the duplicate media box and then updating the translation, and let me know if the issue is still happening.

May 2, 2018 at 12:42 pm #1931493

veggekko

Hi Lauren.
Thank you for helping out. I unchecked the "duplicate media" box but No, it still overwrites the DE alt tags after saving the translation page.

May 2, 2018 at 7:57 pm #1942775

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for testing that for me. I think this is actually related to a known issue that our developers are working on. It seems when the alt tags are translated in Media Manager, they translations get overwritten. Please try this as a workaround. I added a test page to your site and this seems to work correctly.

1. Create a new page/post and upload an image.
2. Duplicate the page to a secondary language (or copy content from original).
3. From the translation editor, click on the image and then click the pencil icon to edit the image. Here, add the translations for alt tag, caption, description, etc. directly from the translation editor.P

When you save the image translations this way, the translations do not get overwritten. I tested this by going back and editing the original page and editing the image title in default language and it did not override the translated title.

Please test this way and let me know if it works correctly for you. In a future release, it will be resolved so that you can edit from the media manager.

May 8, 2018 at 2:38 pm #2034226

veggekko

Hi Lauren.

Our images are not implemented via WYSIWYG editor. So they will not show up on the translation screen.
They are regularly embedded via VC.

Best,
Jochen

May 8, 2018 at 8:34 pm #2040273

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

What type of element are they embedded in? Does the element show up in the Translation Editor? It should, and if you change the image URL or SRC there, does it change when the original is updated?

The topic ‘[Closed] Translated media gets overwritten again when translate function is used’ is closed to new replies.