Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Laura 5 months, 1 week ago.

Assigned support staff: Laura.

Author Posts
June 15, 2019 at 5:52 am #4025665

aliS-20

I am trying to: Interlink menus which

Link to a page where the issue can be seen: hidden link

I expected to see: When translated it should take me hidden link

Instead, I got: It tajke me to home page hidden link

June 15, 2019 at 4:41 pm #4028469

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

thanks for contacting us.

I can see the issue, but it seems it's only for that link and just from FA -> EN, not the other way round.

Before further debugging, I'd ask you to:
1. take a backup
2. update WordPress and any other plugin that is not updated
3. increase the WP Memory Limit. PHP memory limit is fine but WordPress uses 40Mb as default. Minimum requirements for WPML are 128Mb.
Add this near the top of wp-config.php file (after the php opening tag) to increase WP memory:

/** WP Memory Limit */
define( 'WP_MEMORY_LIMIT', '256M' );

The wp-config.php file is located in your WordPress root directory. It's the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.
You can check the current WP Memory Limit value from WPML -> Support in the Info section
More info here:
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
https://wpml.org/home/minimum-requirements/
4. try clearing the cache in WPML going to:
WPML -> Support -> "troubleshooting" link -> "Clear the WPML cache" button
Please do a backup first.
5. disable (or enable) the cache for language switcher also in WPML -> Support -> "troubleshooting"

Please let me know the results of these operations.

June 17, 2019 at 12:19 pm #4035269
aliS-20

Thanks for your help. That issue is solved.

But I have another issue regarding using buddypress shortcodes.

Like in : hidden link as you can see content are coming but when translated to Persian it is showing empty content in url : hidden link

Please let me know how to use buddypress shortcodes to get content in Persian/other language.

New threads created by Laura and linked to this one are listed below:

https://wpml.org/forums/topic/buddypress-shortcodes/

June 17, 2019 at 3:37 pm #4036713

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

since the main issue is solved, I split the topic. We try to have only one issue per ticket, so it's easier for others to search the forum. This also allows supporters to be faster and more efficient.