This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Shekhar Bhandari 3 months, 3 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
June 17, 2019 at 9:05 am #4033549

jeanetteR

I work with the Divi theme and the last week or two I'm having problems with links in translations. What used to work perfectly now leaves the original language links which I have to replace manually.
E.g. see the footer of the homepage above: the English site links to German pages for Privacy Policy, Sitemap etc.

June 17, 2019 at 1:05 pm #4035387

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

As discussed I have marked the ticket as normal forum ticket. Could you please test the same issue with a separate page and let us know if that works. If it does I request you to duplicate your homepage and translate it.

Let me know if this helps.

Thanks

June 19, 2019 at 11:34 am #4051129

jeanetteR

Thanks! I'm not a developer so I need more detailed instructions please.
1. So, when I'm testing on a separate (new) page, I need to have the current version of my theme and the WPML Plugin(s)?
2. I get the duplicate the homepage part but how do I translate it again? My duplicated content already would have translations.

I could not wait to solve this problem before migrating the page to its new domain and now it appears that this WPML error is also causing redirects to malfunction. Most of the time redirects to English pages end up at the corresponding German page.
For example, redirect from hidden link to hidden link results in the German page: hidden link

Perhaps that helps to narrow down the possible problem.

June 20, 2019 at 4:37 am #4056613

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

So, when I'm testing on a separate (new) page, I need to have the current version of my theme and the WPML Plugin(s)?

Yes but I think the best way to debug this issue further is to replicate your site on my localhost and perform further debugging.

So, Could you please provide me a backup of your site so I can replicate your site on my localhost and perform further debugging.

To send a backup file you can use backups plugins, or use hosting services back up and send it using google drive, dropbox, etc to us. If you can, I request you to remove the uploads folder from the backup as it will be easy to download due to the size.

I have enabled the private reply so you can send those links in the private reply. If you use some backup plugins installed and you created the packages, you can just provide login details and mention us, we can download it from the site itself.
hidden link

Look forward to your reply.

Thanks

June 21, 2019 at 9:55 am #4066015

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I can reproduce the issue on my localhost, but I noticed that you are using an outdated version of the divi theme so could you please update the plugin and let me know if that helps?

Further, until we solve the issue, I request you to add the links manually to solve the issue, for example, add all the links in a single text fields

<h4>Sitemap</h4><br/>
<h4><a href="<em><u>hidden link</u></em>">Impressum</a></h4><br/>
<h4><a href="<em><u>hidden link</u></em>">Datenschutz</h4><br/>
<h4><a href="<em><u>hidden link</u></em>">AGB</h4>

and let me know if that helps?

Also, I would like to know if this link is loaded from global divi library?

Look forward to your reply.

Thanks

June 24, 2019 at 10:29 am #4076495

jeanetteR

Thank you!

I updated the theme and WPML plugin and replaced module links with text links. The problem remains the same.

Yes, the one I'm testing with is a global module. It's a footer element used across the site.

June 24, 2019 at 12:10 pm #4077053

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I am debugging this issue right now and still unable to find the source, the issue is not happening on fresh installation so it's hard to replicate.

Being so, I tested the following steps and it's working properly so could you please let me know if that is a viable solution for you?
- Go to Divi Library
- Change the language to second language and delete the global module for Footer Main
- Delete the module from trash too.
- Retranslate the global module
- Check the issue.

Let me know if this helps.

Thanks

The topic ‘[Closed] Translated modules keep original language links’ is closed to new replies.