This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by arnoldS-2 5 months ago.

Assigned support staff: Andreas W..

Author Posts
March 13, 2019 at 7:56 am

arnoldS-2

I am trying to: Translate this English Page;

hidden link

into French here;

hidden link

Instead, I got: English content after using WPML's Classic Translation Editor

March 13, 2019 at 3:03 pm #3335319

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

I am not able to access the wp-admin. Are you using a plugin to change the directory of the login panel?

Please verify your URL for /wp-admin and provide it again. Your next reply is set to private.

I further tried to import your backup file on a test-site but the process was unsuccessful. Could you please use the Duplicator Plugin instead? It will worj unless your website is bigger than 500MB. You can exclude uploads and backups before creating the package.
https://wordpress.org/plugins/duplicator/

About the issue, in case you are using a page builder, please go to WPML -> Setting -> Post type translation and revise if the types used by your page builder are set to "translatable.

I can see that many contents, like title, menus and widgets are already translated. Please go to your main language page editor of your Frontpage and verify the multilingual content setup at the end of the page.

Here you will find the custom fields related to the page building elements. Please try to identify the field responsible for the page content and set it to translate. You will get more field option by clicking "show system fields".

Let me know if you need further help.

Kind regards
Andreas

March 13, 2019 at 8:35 pm
March 13, 2019 at 10:44 pm #3338707

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I connected to the website and I can not see the page that you mentioned in your first message.

Also the provided credentials do refer to a different website named hidden link.

The page hidden link does not exist here.

Further, I am still not able to access the logn (wp-admin) for hidden link.

Please verify the access information and I will be taking care about the issue as soon as possible.

Kind regards
Andreas

March 14, 2019 at 8:16 am #3341273

arnoldS-2

I do apologise (again). I was mixed up with another ticket. I have re-entered the correct details in the above private message.

1. "please go to WPML -> Setting -> Post type translation and revise if the types used by your page builder are set to "translatable." I have attached screen grab.

2. "Please go to your main language page editor of your Frontpage and verify the multilingual content setup at the end of the page." - I have attached screen grab.

3. "Please try to identify the field responsible for the page content and set it to translate. You will get more field option by clicking "show system fields"." - I have attached screen grab.

Please keep in mind I DO NOT want to copy the same Gallery in English across to French. I have translated meta "Title" "Caption" etc for every image per language. So one image will have its own Title in English, Hebrew and French.

I have to set this up manually in every page per languange in the "Gallery" Section.

I have a question. What are Blocks (wp_block) seen in Post Types, (look at screen grab)

I have installed Duplicator, however find it more complicated than my preferred UpdraftPlus. If you need to make a duplicate, you are most welcome to do so; however do not backup Uploads as I have a massive amount of images uploaded to the site.

I appreciate your help with this.

March 14, 2019 at 11:02 pm #3349053

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

The wp_block is related to Gutenberg Blocks. I have enabled it and also tried to disable the Classic Editor Plugin, but your page content is not getting translated.

Could you please try to run the site in minimal setup to see if the issue persists?

Please disable any additional plugin that is not related to WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.
More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

I was going to create a Duplicator package but you site is very huge as you said. Please try those tests first and we will see if further steps are necessary.

Let me know about the results and we will able to further assist you.

Kind regards
Andreas

March 14, 2019 at 11:28 pm #3349143

arnoldS-2

The only thing that changed with the site to cause the translations to not work were updates in WPML.

Keep in mind the translations DID work and now they don't with the same plugins and Theme.

Manually translating a page directly works.

Deactivating plugins does not make a difference. You must have changed the Theme because I lost all my widgets and had to reinstall them. Loosing widgets normally happens when Themes are changed.

You are welcome to duplicate the site and debug it on your end.

Thank you

March 15, 2019 at 5:37 pm #3356115

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I tried to create a Duplicator Package from your site but without filters the site has a size of more than 23GB. Applying the filers that are available for your custom folders the creation of the package caused an error.

I would kindly like to ask you to create the package yourself and top provide in your next private reply.

Further, you explained that the issue appeared after the last update. Coudl you please try to downgrade WPML to see if the issue persists?

You can find older versions of our plugins here:
https://wpml.org/account/downloads/

Simply click on the small blue icon at the right side of each plugin to obtain access to older versions.

Anyhow, if you take a look at the following test site you will find a fresh install of WordPress 5.1.1, the TwentySeventeen Theme, the Classic Editor Plugin, WPML Mulitlingual CMS, Translation Management, String Translation and WPML Media at their latest version. There is not any issue translating pages or posts with the current setup.

You can find the test site here:
hidden link

This should mean that if on your website are currently issue that they are caused to your Theme or are caused by a compatibility issue with another plugin, that possible occurred after the last update.

It is important for us to clarify if the issue is theme related or if it is related to another plugin in order to assist you about this problem.

It would be helpful if you could add the Lense Theme and your Lense Child Theme to this test site for further investigation.

Kind regards
Andreas

March 17, 2019 at 7:43 am #3362863

arnoldS-2

Thank you for your reply Andreas

In response to;

"I tried to create a Duplicator Package from your site but without filters the site has a size of more than 23GB. Applying the filers that are available for your custom folders the creation of the package caused an error.

I would kindly like to ask you to create the package yourself and top provide in your next private reply."

I am not conversant with Duplicator. If you do not have the know how how to use Duplicator which is WPML's preferred migration method; I certainly cannot. I am perplexed you asked me. The bulk of space used relate to the uploads. I guess this is not crucial to replicating the issue WPML is having. I am talking about translating simple pages without any images. If you personally are having issues using Duplicator I kindly suggest referring the matter within WPML. I do not have any knowledge about this plugin.

In response to:

"Further, you explained that the issue appeared after the last update. Coudl you please try to downgrade WPML to see if the issue persists?"

The Editor used to work. I am not in a position as to when exactly it started to cause issues. I can tell you it worked with the exisiting Theme and plugins.

In response to:

"Anyhow, if you take a look at the following test site you will find a fresh install of WordPress 5.1.1, the TwentySeventeen Theme, the Classic Editor Plugin, WPML Mulitlingual CMS, Translation Management, String Translation and WPML Media at their latest version. There is not any issue translating pages or posts with the current setup."

I do not understand the point of this exercise. I have used WPML for a couple of years now and found both simple errors attributed to settings and other serious and very complicated issues that took weeks for your advanced support to investigate the cause and find a solution. I have other sites which had problems and have been fixed and are working now. So I am aware WPML can work. This was to an extent a waste of time.

In response to:

"This should mean that if on your website are currently issue that they are caused to your Theme or are caused by a compatibility issue with another plugin, that possible occurred after the last update.

It is important for us to clarify if the issue is theme related or if it is related to another plugin in order to assist you about this problem."

This is absolutely NOT a certainty. It is a possibility. The time to it took to write your reply, you could have quickly confirmed, (as I said) it does not appear to be Theme or plugin related.

In any case I did switch the Theme to TwentySeventeen and used the Editor on a previously translated page in French to make a minor update and the page content turned back to English. Leaving the site in TwentySeventeen, I deactivated all the plugins except for the remaining ones:

CSSIgniter Shortcodes
Lense theme-specific plugin
WPML Media
WPML Multilingual CMS
WPML String Translation
WPML Translation Management

I translated another (already translated page) into French with a minor change and the content reverted back to English.

I am able to clone this exisitng site to an online testing site without the Media (uploads) if this will help you debug the problem. This way you will be working with a site where the problem exists and in theory, should be duplicated. (I would ask you try Duplicator again with added support on your side).

In the interim I will add the Lense Theme and Lense Child Theme to this test site as requested. I will not be surprised if the issue is NOT duplicated. As I said, the Editor did work.

I ask you do no testing on my live site as it causes widget issues and translations become lost!

Thank you for your assistance.

March 17, 2019 at 9:32 pm #3364839

arnoldS-2

If you have problems migrating my site please refer it to https://wpml.org/forums/users/itamar/ as he has successfully migrated my sites in the past. He will be able to help you how to do it.

March 19, 2019 at 1:46 am #3374193

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I tried to day to run the Duplicator Package with filters on uploads and backups twice and it always gets stuck on 65%. Possible the reason is that the site even with filters still has 10GB. It seems your Database is pretty big, might be?

It is true that we used to able to migrate sites to our server, but due to capacity limitations it is not possible at the moment. Could you please provide me a copy of your wp-content folder without uploads and backups, a copy of your themes folder and a backup of your database?

This way I will be able to install the most important content only on a new WordPress Installation.

Kind regards
Andreas

March 19, 2019 at 5:39 am #3375793

arnoldS-2

Hello,

I am happy to provide a copy of my wp-content folder wihout uploads and backups and a copy of my Themes folder and a backup of my database.

I have given you ftp access so you can download the relevant folders.

I do not know the process to facilitate a backup of my database for a third party.

I am happy for you to direct me what steps to take.

March 19, 2019 at 5:03 pm #3381857

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

Thank you for your message.

You can simply download the wp-content folder by FTP and provide it in the answer to this message. Alternatively you might upload the folder to file service and provide me the download link.

About the database you can access the PHPmyAdmin of your site or you can use the plugin ARI Adminer. Then export a .sql-files as databse backup. Make sure it includes all the tables (no filters) and provide me this file as well.

Thank you!

Kind regards
Andreas

March 19, 2019 at 9:21 pm #3383489

arnoldS-2

My issue is not resolved now. I give up on your support!