We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Carlos Rojas 9 months, 3 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
January 17, 2019 at 2:05 pm #3102290

eeaV

I am trying to:
Wiew back end editor of translated page even though translated language is hidden from site users

Link to a page where the issue can be seen:
Issue appears on back end = no link.
screenshot 01-backend-fail shows the issue

I expected to see:
Interface with Divi Back end elements like in screenshot: 02-backend-ok

Instead, I got:
Interface without Divi back end elements like in screenshot: 01-backend-fail
Front end layout seems to show partly where back end elements should be.

This happens when the language (English in this case) is hidden in the WPML Languages setup.
If the language is not hidden the back end looks as expected.

I would like to be able to edit a translation while having it hidden from users in order to publish it once completed. This used to be possible.

January 17, 2019 at 5:12 pm #3103147

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Could you tell me if the issue persists after increasing the memory limit?

Kind regards,
Carlos

January 17, 2019 at 9:04 pm #3103804

eeaV

Hello Carlos

I have increased memory to 128.
The change is reflected in 'Support' page from WPML menu.

However the problem still persists.

Best Regards
eeaV

January 17, 2019 at 10:16 pm #3103971

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi eeaV,
Thank you very much for your message.

In this case I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

January 21, 2019 at 1:56 pm #3112732

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi eeaV,
Thank you very much for the information provided.

I was able to reproduce the issue in the site. I would like to ask you to follow this steps:
- As the Advance Translation Editor is acive please translate the page using it by clicking on the plus (+) symbol.

Could you tell me if the issue disappear after following the steps above?

Regards,
Carlos