This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Noman 2 months, 3 weeks ago.

Assigned support staff: Noman.

Author Posts
July 22, 2019 at 8:58 am #4255065

victorB-21

After translating a page and publishing it, it would not show it on the website. It would simply lead to a blank page.

July 22, 2019 at 10:05 am #4255841

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Could you please follow below steps and let me know how it goes?

1. I have noticed that your website’s WP Memory Limit is 64MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 64Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '512M');
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

2. Please make sure you are using updated version of Theme and WPML plugins.

3. Please delete all sorts of caches on your site / server cache (if any) / plugin cache (WP Rocket Cache) / CDN cache (if any), clear browser cache and then check the page.

4. If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Thank you

July 25, 2019 at 8:33 am #4280833

victorB-21

Hi, Noman!

Thank you for your email.

We have increased the memory limit, as well as deleted all caches, however the problem remains.

We have learned that there might be some incompatibility happening between the WPML plugin and our website. We are expecting to receive some updates from your colleague who is on our case.

Thank you.

July 25, 2019 at 3:50 pm #4284877

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Ok I see some conversation going on in your other ticket. I hope things go ok for you.

Thanks

The topic ‘[Closed] Translated page does not show’ is closed to new replies.