Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: I have translated my BLOG PAGE using WPML editor and it doesn't appear correctly on the translated website.

Solution: Just simply go to WPML → Settings → Translated documents options and changed the Document status option to Same as the original document. It seems that the translated post had the draft status due to this option (not published) and that's the reason why the post was not visible on the translated blog page.

0% of people find this useful.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by zuzannaR 4 months, 2 weeks ago.

Assigned support staff: Radu.

Author Posts
March 16, 2020 at 7:57 pm #5696243

zuzannaR

Hi!

I have translated my BLOG PAGE using WPML editor and it doesn't appear correctly on the translated website.

First of all, I want to say that the page itself contains only one word (title) that has been translated. It doesn't contain any body text. On the WPML end the page is 100% translated.

On the English website (original language), the Blog page uses a Blog Grid Elementor feature that populates blog posts + excerpts. Currently, there are 3 posts visible on the English Blog page. See below:

hidden link

I have translated one of the posts into Spanish and for some reason, it doesn't populate on the Spanish Blog page. The Spanish Blog page is just empty. See below:

hidden link

I can see the post translated correctly when I access it directly from the link, but I need it to be visible on the Spanish Blog page.

English blog post:
hidden link

Spanish blog post:
hidden link

Can you please advise what the problem might be?

March 17, 2020 at 9:15 am #5699733

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Zuzanna,

I checked the structure of the blog page in English and it seems that it's using an Elementor module on it, to display the posts.

In this case, can you edit the English blog page, change the language to Spanish using the language switcher from the top admin bar, edit the translated page using Elementor, and see if the blog posts are appearing this time, please?

If this is not working once you made the change, please give me access to the dashboard area and I'll have a look at the blog page too.

Thanks,
Radu

March 18, 2020 at 3:33 pm #5712471

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Zuzanna,

Can you give me admin rights, please? Only this way I can have a look at all the settings and see what might be causing this issue on your website. I promise I won't change anything else, I just want to check the settings.

Thanks,
Radu

March 18, 2020 at 3:42 pm #5712505

zuzannaR

Hi Radu,

Sorry for this - I've accidentally set you as Author instead of Administrator.
I've fixed that and now you have admin rights.

Thanks!

March 19, 2020 at 8:35 am #5717241

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Zuzanna,

Can you check again the Blog page in Spanish, please? Basically, what I did is go to WPML → Settings → Post Types Translation and select the Translatable - use translation if available or fallback to default language option for the posts.

Also, as I can see, there's only one post translated to Spanish (for now) which wasn't displayed at first on the Blog page either. What I did is edit the Spanish version of the post (hidden link) and simply hit the Update button on the top right corner.

Please have a look at the blog page now and tell me if you still have any issues with it.

Thanks,
Radu

March 19, 2020 at 9:15 am #5717755

zuzannaR

Thank you, Radu! I can see the Spanish translation now.

I have few questions just to understand the process:

1. "What I did is edit the Spanish version of the post and simply hit the Update button on the top right corner." Do you mean you opened it in WP Admin > Posts, or in Elementor?

2. Will I need to do it for every post, or will the posts from now on appear automatically on the Spanish web once the translation is finished?

3. Right now only one post has been translated into Spanish and the other 2 are still in English.
I would ideally want the Spanish web to show only that one translated post. The other 2 posts should appear there only once they are translated.

Is there any option in WPML that would allow this? If not, it's not a big deal, I'll figure out my own workflow for future publications.

Thanks!

March 20, 2020 at 11:53 am #5727641

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Zuzanna,

1. What I mean is edit the post in English, use the top admin language switcher, select Spanish, and then hit the Publish button on the top right corner.

2. The translation should appear automatically. Can you try to translate one more post and tell me if you still have this issue, please? I'm thinking that everything will work fine from now on.

3. In order to display only the translated posts on the blog page, all you have to do is go to WPML → Settings → Post Types Translation and select the Translatable - only show translated items for the Posts. This will make the Spanish page display only the Spanish translated posts.

Thanks,
Radu

March 20, 2020 at 6:26 pm #5730139

zuzannaR

Hi Radu,

Re point 2:
I've created a new English post and translated it into Spanish.
The English post appeared on the EN web, but the translation didn't.
I had to follow the steps you described in point 1 and only then the post appeared on the ES web.

I don't mind following your instructions from step 1 every time I want to publish a translated post, but if it should appear automatically after the translation is completed, then something is not working correctly.

(I've deleted the post, because it was just a test post, but feel free to create a new one to test it).

Thanks and have a nice weekend!

March 23, 2020 at 5:15 am #5738063

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Zuzanna,

I hope you had a great weekend!

I created a new post on your website, translated it and, as you said, the issue is still there.

I also tried to create the same post on my website using WPML and Elementor, and everything worked fine. In this case, could you try to deactivate all the plugins except for WPML and Elementor, activate a default theme (like Twenty Nineteen), and try again to translate a post, please?

This way we can make sure that no plugin (or theme) that you're using is causing this issue. Please give this a try and tell me how it goes.

Thanks,
Radu

March 23, 2020 at 8:06 pm #5745323

zuzannaR

Hi Radu,

I did as advised, but when I go to the blog page using a default theme, the page is blank. There are no blog entries at all.
In my current theme (Blacksilver), I use an Elementor feature to display blog entries. When I switch to the default theme, the Elementor feature somehow doesn't work.

March 25, 2020 at 11:21 am #5759723

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Zuzanna,

Can you try to create a new post, translate it, then check again the Spanish blog page, please? Everything should work fine now (I created a new post now and it works as expected).

All I did was go to WPML → Settings → Translated documents options, and changed the Document status option to Same as the original document. It seems that the translated post had the draft status due to this option. Now everything should work fine.

Thanks,
Radu

March 25, 2020 at 9:31 pm #5764229

zuzannaR

Thank you, Radu! It worked 🙂