This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Translated page goes blank except header and footer, ACF fields not showing

Solution: The fields weren't configured correctly, correctly configuring the fields as shown in the documentation solve the issue.

Relevant Documentation: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

This topic contains 10 replies, has 2 voices.

Last updated by sarahT-6 2 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
August 6, 2019 at 5:11 pm

sarahT-6

I fully translated a page and when I go to that translated page(chinese) the content area is blank. When I go to edit the page and then switch to another language(chinese), the acf fields are not showing on the backend.

chinese page here: hidden link

You can see only the header and footer. I tried just copying the english content to japanese and still shows no content.

I have tried:

1. settings -> multilingual content setup -> custom fields translations -> some I used 'copy' and some I used 'translate'

2. settings -> multilingual content setup -> custom fields translations -> show system fields -> some I used 'copy' and some I used 'translate'

3. custom fields -> home page fields -> Make 'Field Groups' translatable

4. custom fields -> home page fields -> field -> translate, some fields i did copy

August 7, 2019 at 3:43 am #4351857

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The issue seems unusual, let’s get this sorted out right away.

For system fields, please use "copy" the fields instead of translate.

I marked the "_home_page_layout" flexible content system fields as copy and I can see it's working properly, so can you please check the issue once?

Thanks

August 7, 2019 at 2:35 pm #4356049

sarahT-6

This worked, I can see the content on the front end but what about the acf fields if the client needs to change something on the chinese backend? Nothing is showing there still.

August 7, 2019 at 2:37 pm #4356051

sarahT-6

Also, some of the background images are not copying over onto the chinese page too.

August 8, 2019 at 3:27 am #4359447

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The best way to translate the ACF is by using Translation Editor, so if you open the page in Translation Editor you should be able to see them.

If you want to edit the ACF using the standard WordPress Editor, you will need to translate the field groups first to those languages, more details here: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#translating-acf-user-interface

Also, some of the background images are not copying over onto the Chinese page too.

Have you set the images field name as well as system fields as a copy? If the problem still exists, can you provide me a screenshot of the backend and front-end so I can quickly debug it?

Look forward to your reply.

Thanks

August 8, 2019 at 1:50 pm #4363467

sarahT-6

Can you please provide a screenshot of where you changed - "I marked the "_home_page_layout" flexible content system fields as copy and I can see it's working properly, so can you please check the issue once?"

I want to save this screenshot for the future.

You have my credentials already, can you not check if I have the fields as copy? Where is this done? on the wpml settings or at the bottom of the actual page? It's confusing that there are 2 of the same options.

August 9, 2019 at 3:46 am #4367173

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Sure, the screenshot is attached.

You have my credentials already, can you not check if I have the fields as a copy? Where is this done? on the wpml settings or at the bottom of the actual page? It's confusing that there are 2 of the same options.

I am not sure which exact fields you are talking about so I request you to check it.

It can either be done in WPML settings or at the bottom of the actual page, both settings are synchronized so if you make changes any of them, it will work properly.

Let me know if this helps.

Thanks

August 13, 2019 at 7:13 pm #4390379

sarahT-6

The same problem is happening for other pages. I did the exact same thing you did, I copied the flexible content fields.

This is happening on the chinese side, our product page and our farm.

August 13, 2019 at 7:55 pm #4390497

sarahT-6

Ok I figured out my issue. I noticed there are duplicates of the fields, so I was saving one but not the other.

Another question for you. The chinese pages changed their slugs to the chinese but one of them is still english with the /zh-hans/ . I think I would rather the slug in english. Is it possible to change it back without breaking things? What are the steps to this?

August 14, 2019 at 4:22 am #4392389

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Glad to hear that it now works. As the original issue is resolved may I kindly ask you please to open a new ticket for your additional question?

As per our support policies, we can only handle one issue per ticket. It will help us to serve you better and we can avoid discussing multiple problems in one ticket.

Thanks

August 14, 2019 at 1:38 pm #4395567

sarahT-6

My issue is resolved now. Thank you!