This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 2 voices.

Last updated by Carlos Rojas 2 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 31, 2019 at 9:00 am

matteoG-23

I have uncode theme installed, everything is updated and translated but my translated homepage looks different from the original.
The original hidden link
Translated hidden link

I've seen this thread https://wpml.org/forums/topic/format-difference-in-translated-pages/
but his solution made my problem worse because now the header in the translated page isn't showing at all and the original problem remains
(the original problem was in the "timorasso" section which has a white background instead of a black one as the original and the "vini" section that shows the featured media instead of a custom one as the original page)

July 31, 2019 at 2:00 pm #4315039

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

Please visit this link where you will find the steps to follow in order to translate the Uncode theme correctly using WPML: https://wpml.org/documentation/theme-compatibility/build-multilingual-wordpress-websites-using-uncode-theme-and-wpml/

Kind regards,
Carlos

July 31, 2019 at 2:37 pm #4315419

matteoG-23

Hi Carlos, I've already followed this guide but ended up with the problem!
I've translated the content block used for the header, the page itself and the content block for the footer. I used the ATE for everything.

August 1, 2019 at 10:55 am #4320765

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you for your message.

I took a deeper look at the site and the cause of the issue is that some shortcodes aren't registered for WPML to fetch. To solve this issue you need to follow the steps described in this link: https://wpml.org/documentation/support/language-configuration-files/#page-builder-content

You can add the XML content in WPML -> Settings -> Custom XML Configuration tab.

To find the missing shortcodes just edit the front page and click on the 'Classic mode' button. This will show you all the content of the page and all the shortcodes used.

Regards,
Carlos

August 1, 2019 at 3:36 pm #4323491

matteoG-23

I can't find the missing shortcodes and the header is missing and I don't know why. At first it was showing than disappeared.
Can you help me?

August 1, 2019 at 6:30 pm #4324693

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I will take another look at the issue and will try to solve the original issue (the one with the missing shortcodes). I will get back to you as soon as I finish.

If the issue with the header persists after I finish testing then I will ask you to open a new ticket and assign it directly to me.

Regards,
Carlos

August 2, 2019 at 9:09 am #4328385

matteoG-23

I've temporarily solved editing the translated page with the composer because I need the site online but it would be great to find what cause the issue (the shortcodes that are missing)
Thanks for your work!

August 2, 2019 at 4:44 pm #4331541

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I added some XML code in WPML -> Settings -> Custom XML Configuration tab. I would like to ask you to create a test page and add the same content as the homepage and then translate it. This way we can check if we still need to add more XML code.

Regards,
Carlos

August 5, 2019 at 9:45 am #4339443

matteoG-23

Hi Carlos! I tried to build a new page with the same content as the homepage and then I translated it.
- Good news: the header shows up
- Bad news: still got the issue on the "timorasso" section and "our wine"

For the timorasso section, I have found out that the problem is related to the general page attribute of the skin. The translated page at the "skin" voice has the value "inherit" while the original page is set to "dark" skin.
For the "our wine" section, which has a post element that shows the portfolio, I don't know why it doesn't maintain the custom media and use the featured image instead.

August 5, 2019 at 2:04 pm #4341125

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for this feedback.

I made a few changes in the code and it should work now. I kindly ask you to follow this steps:
- Edit the test page in Italian -> Make a small change in the content, specially in the mentioned sections -> Save the changes -> Update the translation.

If you see content that you don't understand just copy it to the translation. This is the way the information about the images is stored by the shortcodes.

Could you tell me if the issue is solved?
Regards,
Carlos

August 6, 2019 at 7:49 am #4344777

matteoG-23

Hi Carlos! Well, for a start, thanks for your work!
Then I can tell you that the problem of the skin is fixed but unfortunately not the other one!
I've found some text as you said and as you can see in the image but still doesn't work! I'm sorry

August 6, 2019 at 11:35 am #4346811

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Watching the attached image in your message I can see that the post type is portfolio and then you have the IDs of the selected portfolios. You will need to substitute the IDs of this portfolios with the IDs of their respective translation.

You can get the ID of the portfolio from the edit URL.

Please let me know if this solves the issue.
Regards,
Carlos

August 7, 2019 at 7:01 pm #4357637

matteoG-23

Hi Carlos,
I tried to change the portfolio ID inside the ATE as you said but I still don't get the custom media, still got the featured image! I don't know where is written that information and I can't find it!
And I'm really sorry to say this but, in the portfolios, there is one thing that doesn't show up in
ATE. It's a regular icon box and it's the same in every portfolio

August 7, 2019 at 8:51 pm #4358211

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you for your feedback.

I would like to ask your authorization to try to make the changes in the site. Before you authorize me I kindly ask you to confirm you have a full backup of the site to restore if necessary.

Looking forward to your message.
Regards,
Carlos

August 12, 2019 at 4:00 pm #4382079

matteoG-23

I have a backup copy and you have my authorization to try to make the changes in the site.
Thanks!