This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Carlos Rojas 3 months, 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
June 25, 2019 at 8:46 am #4082345

jen-tsungH

I am trying to: first test translated page for English, Simplified Chinese & Traditional Chinese.

Link to a page where the issue can be seen:hidden link

I expected to see: Chinese language page comes out when selected.

Instead, I got: Selected language page jumps back to English homepage.

June 25, 2019 at 1:31 pm #4084945

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to ask you to follow this steps:
- Back up your site first before making any change
- Go to Woocommerce -> Woocommerce Multilingual -> Status tab -> Solve any problem that might appear.
- Go to Woocommerce -> Woocommerce Multilingual -> Settings tab -> Troubleshooting link (bottom right) -> Sync all the products.

Could you tell me the result of the steps above?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

June 26, 2019 at 3:39 am #4088597

jen-tsungH

Hi Carlos,

Thank you for your information.

I did the first step
1. - Go to Woocommerce -> Woocommerce Multilingual -> Status tab -> Solve any problem that might appear.
- Go to Woocommerce -> Woocommerce Multilingual -> Settings tab -> Troubleshooting link (bottom right) -> Sync all the products.

2. I increased the PHP memory to 256MB.

When selected other Language, the product page will jump back to English homepage.

Here is the product page: hidden link

Please test it, when you select other language, it will back to English homepage.
Please advise me, where may be set wrong or what should I do next?

Thanks,

Jen Tsung, Huang

June 26, 2019 at 11:08 am #4091853

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Jen Tsung,
Thank you very much for your feedback.

In this case I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

June 27, 2019 at 11:08 am #4099439

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

I visited the site and applied some troubleshooting options. At this point I need to ask you to translate the product hidden link to both Chinese Simplified and Chinese Traditional following the steps described in this link: https://wpml.org/documentation/related-projects/woocommerce-multilingual/#translating-products

Could you confirm that the issue is solved?
Regards,
Carlos

June 28, 2019 at 12:56 am #4103285

jen-tsungH

Hi Carlos,

I translated the product as your requested.
Please check it, see what is outcome.
And what is the major problem for my translate issue.

Thanks,

JEN TSUNG HUANG

June 28, 2019 at 12:25 pm #4107375

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi JEN TSUNG HUANG,
Thank you for your message.

I double checked the product and all seems to be working correctly. I recommend you to visit this link where you will find our official documentation on how to translate Woocommerce using Woocommerce Multilingual: https://wpml.org/documentation/related-projects/woocommerce-multilingual/

Could you confirm that the issue is solved?

Best regards,
Carlos

July 1, 2019 at 8:42 am #4116675

jen-tsungH

Hi Carlos,

The problem still there.

I could translate the homepage or other webpages.
I have followed the instruction to do so, he product translation still not work for me.

We found that the product translation could not saved, after saved the product in different language, and go back to reopen it again, the product language data missed.
Will that be the problem of my website with WPML?

And this is my second website which use WPML, and this one is not working well.

If you have any other suggestion what to do, I will try it.
If no, I think, we can close the case, but not problem solved.

Thanks,

JEN TSUNG HUANG

July 1, 2019 at 11:17 am #4118231

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your message.

In this case I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Update all outdated plugins and themes.
- Flush all cache memory
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Regards,
Carlos

July 7, 2019 at 3:42 am #4157093

jen-tsungH

My issue is resolved now by other solution. Thank you!

July 8, 2019 at 5:00 am #4159063

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos